summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.5.0.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2018-01-30 16:58:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 11:06:27 +0000
commita62c43a363245740c9a7250e5795983197a46896 (patch)
tree6b83fe30743e9701834bb42d54444b02b6bd908b /meta/recipes-devtools/ruby/ruby_2.5.0.bb
parent5f0c4c785d7c6daa25cfd5e4ff939afb0ff2294a (diff)
downloadpoky-a62c43a363245740c9a7250e5795983197a46896.tar.gz
ruby: 2.4.2 -> 2.5.0
1.Upgrade ruby form 2.4.2 to 2.5.0. 2.Update the checksum of LIC_FILES_CHKSUM. 3.Delete ruby-CVE-2017-9224.patch, ruby-CVE-2017-9227.patch, ruby-CVE-2017-9229.patch, since it is integrated upstream. 4.Modify ruby-CVE-2017-9226.patch, since the data has been changed. (From OE-Core rev: 67b9f407f7c40c63c7f9518b4ee3d4d1cc7c75ce) Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.5.0.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.5.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.5.0.bb b/meta/recipes-devtools/ruby/ruby_2.5.0.bb
new file mode 100644
index 0000000000..1ac7f2aa5a
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.5.0.bb
@@ -0,0 +1,49 @@
1require ruby.inc
2
3SRC_URI += " \
4 file://ruby-CVE-2017-9226.patch \
5 file://ruby-CVE-2017-9228.patch \
6 "
7
8SRC_URI[md5sum] = "f4711f856fe14de222b9da3d3b8efa89"
9SRC_URI[sha256sum] = "46e6f3630f1888eb653b15fa811d77b5b1df6fd7a3af436b343cfe4f4503f2ab"
10
11# it's unknown to configure script, but then passed to extconf.rb
12# maybe it's not really needed as we're hardcoding the result with
13# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
14UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
18
19PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
20PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp"
21PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
22
23EXTRA_AUTORECONF += "--exclude=aclocal"
24
25EXTRA_OECONF = "\
26 --disable-versioned-paths \
27 --disable-rpath \
28 --disable-dtrace \
29 --enable-shared \
30 --enable-load-relative \
31"
32
33do_install() {
34 oe_runmake 'DESTDIR=${D}' install
35}
36
37PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
38
39SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
40RDEPENDS_${PN}-ri-docs = "${PN}"
41FILES_${PN}-ri-docs += "${datadir}/ri"
42
43SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
44RDEPENDS_${PN}-rdoc = "${PN}"
45FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
46
47FILES_${PN} += "${datadir}/rubygems"
48
49BBCLASSEXTEND = "native"