summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.4.2.bb
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-10-12 11:35:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-07 15:57:44 +0100
commit82528b2f84f2d519bb670ee12fa16257192e6fe9 (patch)
tree4b2ae1b3c29b6989cb47d075a5f58fec54db4777 /meta/recipes-devtools/ruby/ruby_2.4.2.bb
parent5c9e4bbba7c5f604b366815ad5f776c2d6c17b06 (diff)
downloadpoky-82528b2f84f2d519bb670ee12fa16257192e6fe9.tar.gz
ruby: upgrade to 2.4.2
The CVE-2017-14064 patch is already at 2.4.2 as explained on project's commit, so removing from the recipe & repo. commit 83735ba29a0bfdaffa8e9c2a1dc025c3b0b63153 Author: hsbt <hsbt@b2dd03c8-39d4-4d8f-98ff-823fe69b080e> Date: Wed Apr 12 00:21:18 2017 +0000 Merge json-2.0.4. * https://github.com/flori/json/releases/tag/v2.0.4 * https://github.com/flori/json/blob/09fabeb03e73ed88dc8ce8f19d76ac59e51dae20/CHANGES.md#2017-03-23-204 git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58323 b2dd03c8-39d4-4d8f-98ff-823fe69b080e (From OE-Core rev: 6e37a88af155d5e5453fb0f44bb11d6f8e406438) (From OE-Core rev: 4562790471c7e3f3e393cd3e8b77d28ed4196452) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> [Fixup for pyro context] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.4.2.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.4.2.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.4.2.bb b/meta/recipes-devtools/ruby/ruby_2.4.2.bb
new file mode 100644
index 0000000000..b471154a22
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.4.2.bb
@@ -0,0 +1,52 @@
1require ruby.inc
2
3SRC_URI += " \
4 file://ruby-CVE-2017-9224.patch \
5 file://ruby-CVE-2017-9226.patch \
6 file://ruby-CVE-2017-9227.patch \
7 file://ruby-CVE-2017-9228.patch \
8 file://ruby-CVE-2017-9229.patch \
9 "
10
11SRC_URI[md5sum] = "fe106eed9738c4e03813ab904f8d891c"
12SRC_URI[sha256sum] = "93b9e75e00b262bc4def6b26b7ae8717efc252c47154abb7392e54357e6c8c9c"
13
14# it's unknown to configure script, but then passed to extconf.rb
15# maybe it's not really needed as we're hardcoding the result with
16# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
17UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
21
22PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
23PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp"
24PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
25
26EXTRA_AUTORECONF += "--exclude=aclocal"
27
28EXTRA_OECONF = "\
29 --disable-versioned-paths \
30 --disable-rpath \
31 --disable-dtrace \
32 --enable-shared \
33 --enable-load-relative \
34"
35
36do_install() {
37 oe_runmake 'DESTDIR=${D}' install
38}
39
40PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
41
42SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
43RDEPENDS_${PN}-ri-docs = "${PN}"
44FILES_${PN}-ri-docs += "${datadir}/ri"
45
46SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
47RDEPENDS_${PN}-rdoc = "${PN}"
48FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
49
50FILES_${PN} += "${datadir}/rubygems"
51
52BBCLASSEXTEND = "native"