summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.4.1.bb
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-10-12 11:35:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-07 15:57:44 +0100
commit82528b2f84f2d519bb670ee12fa16257192e6fe9 (patch)
tree4b2ae1b3c29b6989cb47d075a5f58fec54db4777 /meta/recipes-devtools/ruby/ruby_2.4.1.bb
parent5c9e4bbba7c5f604b366815ad5f776c2d6c17b06 (diff)
downloadpoky-82528b2f84f2d519bb670ee12fa16257192e6fe9.tar.gz
ruby: upgrade to 2.4.2
The CVE-2017-14064 patch is already at 2.4.2 as explained on project's commit, so removing from the recipe & repo. commit 83735ba29a0bfdaffa8e9c2a1dc025c3b0b63153 Author: hsbt <hsbt@b2dd03c8-39d4-4d8f-98ff-823fe69b080e> Date: Wed Apr 12 00:21:18 2017 +0000 Merge json-2.0.4. * https://github.com/flori/json/releases/tag/v2.0.4 * https://github.com/flori/json/blob/09fabeb03e73ed88dc8ce8f19d76ac59e51dae20/CHANGES.md#2017-03-23-204 git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58323 b2dd03c8-39d4-4d8f-98ff-823fe69b080e (From OE-Core rev: 6e37a88af155d5e5453fb0f44bb11d6f8e406438) (From OE-Core rev: 4562790471c7e3f3e393cd3e8b77d28ed4196452) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> [Fixup for pyro context] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.4.1.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.4.1.bb53
1 files changed, 0 insertions, 53 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.4.1.bb b/meta/recipes-devtools/ruby/ruby_2.4.1.bb
deleted file mode 100644
index f814da9d95..0000000000
--- a/meta/recipes-devtools/ruby/ruby_2.4.1.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1require ruby.inc
2
3SRC_URI += " \
4 file://ruby-CVE-2017-9224.patch \
5 file://ruby-CVE-2017-9226.patch \
6 file://ruby-CVE-2017-9227.patch \
7 file://ruby-CVE-2017-9228.patch \
8 file://ruby-CVE-2017-9229.patch \
9 file://CVE-2017-14064.patch \
10 "
11
12SRC_URI[md5sum] = "782bca562e474dd25956dd0017d92677"
13SRC_URI[sha256sum] = "a330e10d5cb5e53b3a0078326c5731888bb55e32c4abfeb27d9e7f8e5d000250"
14
15# it's unknown to configure script, but then passed to extconf.rb
16# maybe it's not really needed as we're hardcoding the result with
17# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
18UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
22
23PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
24PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp"
25PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
26
27EXTRA_AUTORECONF += "--exclude=aclocal"
28
29EXTRA_OECONF = "\
30 --disable-versioned-paths \
31 --disable-rpath \
32 --disable-dtrace \
33 --enable-shared \
34 --enable-load-relative \
35"
36
37do_install() {
38 oe_runmake 'DESTDIR=${D}' install
39}
40
41PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
42
43SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
44RDEPENDS_${PN}-ri-docs = "${PN}"
45FILES_${PN}-ri-docs += "${datadir}/ri"
46
47SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
48RDEPENDS_${PN}-rdoc = "${PN}"
49FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
50
51FILES_${PN} += "${datadir}/rubygems"
52
53BBCLASSEXTEND = "native"