diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-08-14 15:20:32 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-08-16 14:57:58 +0100 |
commit | 61929f05d78553b9759d15f88ba8fda5accafd1b (patch) | |
tree | a52c04bdc247a3392d66dc2a74e9be133036e0e5 /meta/recipes-devtools/rsync/rsync_3.2.5.bb | |
parent | 6baf9b07a8571c7b0a0b3f5635873059b92059ed (diff) | |
download | poky-61929f05d78553b9759d15f88ba8fda5accafd1b.tar.gz |
rsync: Upgrade to 3.2.5
Changlog is here [1]
[1] https://download.samba.org/pub/rsync/NEWS#3.2.5
(From OE-Core rev: 937a28a2a83abc3923cf2793eb79b0a1f770cd54)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.2.5.bb')
-rw-r--r-- | meta/recipes-devtools/rsync/rsync_3.2.5.bb | 69 |
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.2.5.bb b/meta/recipes-devtools/rsync/rsync_3.2.5.bb new file mode 100644 index 0000000000..a1ba5ea44d --- /dev/null +++ b/meta/recipes-devtools/rsync/rsync_3.2.5.bb | |||
@@ -0,0 +1,69 @@ | |||
1 | SUMMARY = "File synchronization tool" | ||
2 | HOMEPAGE = "http://rsync.samba.org/" | ||
3 | DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer." | ||
4 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" | ||
5 | SECTION = "console/network" | ||
6 | # GPL-2.0-or-later (<< 3.0.0), GPL-3.0-or-later (>= 3.0.0) | ||
7 | # Includes opennsh and xxhash dynamic link exception | ||
8 | LICENSE = "GPL-3.0-or-later" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=24423708fe159c9d12be1ea29fcb18c7" | ||
10 | |||
11 | DEPENDS = "popt" | ||
12 | |||
13 | SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \ | ||
14 | file://rsyncd.conf \ | ||
15 | file://makefile-no-rebuild.patch \ | ||
16 | file://determism.patch \ | ||
17 | " | ||
18 | SRC_URI[sha256sum] = "2ac4d21635cdf791867bc377c35ca6dda7f50d919a58be45057fd51600c69aba" | ||
19 | |||
20 | # -16548 required for v3.1.3pre1. Already in v3.1.3. | ||
21 | CVE_CHECK_IGNORE += " CVE-2017-16548 " | ||
22 | |||
23 | inherit autotools-brokensep | ||
24 | |||
25 | PACKAGECONFIG ??= "acl attr \ | ||
26 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ | ||
27 | " | ||
28 | |||
29 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," | ||
30 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," | ||
31 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | ||
32 | PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4" | ||
33 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" | ||
34 | PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash" | ||
35 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd" | ||
36 | |||
37 | # By default, if crosscompiling, rsync disables a number of | ||
38 | # capabilities, hardlinking symlinks and special files (i.e. devices) | ||
39 | CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes" | ||
40 | |||
41 | EXTRA_OEMAKE = 'STRIP=""' | ||
42 | EXTRA_OECONF = "--disable-md2man --with-nobody-group=nogroup" | ||
43 | |||
44 | #| ./simd-checksum-x86_64.cpp: In function 'uint32_t get_checksum1_cpp(char*, int32_t)': | ||
45 | #| ./simd-checksum-x86_64.cpp:89:52: error: multiversioning needs 'ifunc' which is not supported on this target | ||
46 | #| 89 | __attribute__ ((target("default"))) MVSTATIC int32 get_checksum1_avx2_64(schar* buf, int32 len, int32 i, uint32* ps1, uint32* ps2) { return i; } | ||
47 | #| | ^~~~~~~~~~~~~~~~~~~~~ | ||
48 | #| ./simd-checksum-x86_64.cpp:480:1: error: use of multiversioned function without a default | ||
49 | #| 480 | } | ||
50 | #| | ^ | ||
51 | #| If you can't fix the issue, re-run ./configure with --disable-roll-simd. | ||
52 | EXTRA_OECONF:append:libc-musl = " --disable-roll-simd" | ||
53 | |||
54 | # rsync 3.0 uses configure.sh instead of configure, and | ||
55 | # makefile checks the existence of configure.sh | ||
56 | do_configure:prepend () { | ||
57 | rm -f ${S}/configure ${S}/configure.sh | ||
58 | } | ||
59 | |||
60 | do_configure:append () { | ||
61 | cp -f ${S}/configure ${S}/configure.sh | ||
62 | } | ||
63 | |||
64 | do_install:append() { | ||
65 | install -d ${D}${sysconfdir} | ||
66 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir} | ||
67 | } | ||
68 | |||
69 | BBCLASSEXTEND = "native nativesdk" | ||