diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-08-13 18:54:32 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-08-13 20:10:33 +0100 |
commit | 61addcc8536caef8cd8a2bf7ed3c6c34ce6a7f83 (patch) | |
tree | 420ebbb7dbcd457e3cc398bc85ef694f33853e32 /meta/recipes-devtools/rpm/rpmresolve_1.0.bb | |
parent | 8daf311c3be5d1bb6e0a903c0bdbbf2420454c9b (diff) | |
download | poky-61addcc8536caef8cd8a2bf7ed3c6c34ce6a7f83.tar.gz |
rpmresolve: add wrapper script to fix paths
Fixes sstate relocation due to the path to /etc/rpm being baked into the
libraries - this manifested in the form of the following assertion at
runtime:
rpmresolve: dbconfig.c:493: db3New: Assertion `dbOpts != ((void *)0) && *dbOpts != '\0'' failed.
Fixes [YOCTO #2936].
(From OE-Core rev: 44c2fb7ea0228dd749129d334c76a1bd2983e585)
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpmresolve_1.0.bb')
-rw-r--r-- | meta/recipes-devtools/rpm/rpmresolve_1.0.bb | 9 |
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb index f8750e02ba..3ce4369d0c 100644 --- a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb +++ b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb | |||
@@ -4,7 +4,7 @@ DESCRIPTION = "OpenEmbedded RPM resolver - performs RPM database lookups in batc | |||
4 | DEPENDS = "rpm" | 4 | DEPENDS = "rpm" |
5 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | 6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
7 | PR = "r0" | 7 | PR = "r1" |
8 | 8 | ||
9 | SRC_URI = "file://rpmresolve.c" | 9 | SRC_URI = "file://rpmresolve.c" |
10 | 10 | ||
@@ -19,4 +19,11 @@ do_install() { | |||
19 | install -m 0755 rpmresolve ${D}${bindir} | 19 | install -m 0755 rpmresolve ${D}${bindir} |
20 | } | 20 | } |
21 | 21 | ||
22 | do_install_append_virtclass-native() { | ||
23 | create_wrapper ${D}/${bindir}/rpmresolve \ | ||
24 | RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
25 | RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \ | ||
26 | RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale | ||
27 | } | ||
28 | |||
22 | BBCLASSEXTEND = "native" | 29 | BBCLASSEXTEND = "native" |