summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-03-27 16:19:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-28 08:43:13 +0100
commit8c1c392ca34da1c64336d0aa2d0a26b9c23d8d39 (patch)
tree37f509b2269d4a37cebcde905b84ec2e52c61d18 /meta/recipes-devtools/rpm/rpm_git.bb
parent3d29214b20433a506a3d59cdc08fc1a9be09a5a0 (diff)
downloadpoky-8c1c392ca34da1c64336d0aa2d0a26b9c23d8d39.tar.gz
dnf: move the entire dnf/rpm4 stack to Python 3
[YOCTO #11180] (From OE-Core rev: bedcdc4cf921b70a8cfb16c6684668d0ac9e1942) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_git.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index 9bccd91168..96f71d5bb5 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -13,8 +13,8 @@ simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \ 13other tools that need an intimate knowledge of RPM packages in order \
14to function." 14to function."
15 15
16SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages" 16SUMMARY_python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \ 17DESCRIPTION_python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \ 18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries." 19supplied by the RPM Package Manager libraries."
20 20
@@ -34,6 +34,7 @@ SRC_URI = "git://github.com/rpm-software-management/rpm \
34 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \ 34 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
35 file://0001-Fix-build-with-musl-C-library.patch \ 35 file://0001-Fix-build-with-musl-C-library.patch \
36 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \ 36 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
37 file://0001-Add-PYTHON_ABI-when-searching-for-python-libraries.patch \
37 " 38 "
38 39
39PV = "4.13.90+git${SRCPV}" 40PV = "4.13.90+git${SRCPV}"
@@ -42,10 +43,11 @@ SRCREV = "a8e51b3bb05c6acb1d9b2e3d34f859ddda1677be"
42 43
43S = "${WORKDIR}/git" 44S = "${WORKDIR}/git"
44 45
45DEPENDS = "nss libarchive db file popt xz dbus elfutils python" 46DEPENDS = "nss libarchive db file popt xz dbus elfutils python3"
46DEPENDS_append_class-native = " file-replacement-native" 47DEPENDS_append_class-native = " file-replacement-native"
47 48
48inherit autotools gettext pkgconfig pythonnative 49inherit autotools gettext pkgconfig python3native
50export PYTHON_ABI
49 51
50# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe 52# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
51EXTRA_AUTORECONF_append = " --exclude=gnu-configize" 53EXTRA_AUTORECONF_append = " --exclude=gnu-configize"
@@ -102,9 +104,9 @@ FILES_${PN} += "${libdir}/rpm-plugins/*.so \
102FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \ 104FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \
103 " 105 "
104 106
105PACKAGES += "python-rpm" 107PACKAGES += "python3-rpm"
106PROVIDES += "python-rpm" 108PROVIDES += "python3-rpm"
107FILES_python-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*" 109FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
108 110
109# rpm 5.x was packaging the rpm build tools separately 111# rpm 5.x was packaging the rpm build tools separately
110RPROVIDES_${PN} += "rpm-build" 112RPROVIDES_${PN} += "rpm-build"