diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2012-06-11 13:18:54 -0500 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-06-12 11:10:35 +0100 |
commit | b81d788c799a576dd1dc0db573639df69d91afef (patch) | |
tree | 3a96546c68c947b928fa24d4c52469d2b81133ec /meta/recipes-devtools/rpm/rpm_5.4.9.bb | |
parent | bc4a29df84542f0ef905a2e20d8533a0ea7cb613 (diff) | |
download | poky-b81d788c799a576dd1dc0db573639df69d91afef.tar.gz |
ossp-uuid: Add oss-uuid package and RPM 5.4.9 integration
RPM 5.4.9 now strongly encourages you to have the ossp-uuid library available.
Add this recipe, and change RPM to use the uuid functionality.
(From OE-Core rev: 8a2b55c5b7c544ec15113bc21e5c62276449c9c3)
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.9.bb')
-rw-r--r-- | meta/recipes-devtools/rpm/rpm_5.4.9.bb | 11 |
1 files changed, 8 insertions, 3 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb index 6eba802d8a..2ca0f58ff0 100644 --- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb +++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb | |||
@@ -42,8 +42,8 @@ HOMEPAGE = "http://rpm5.org/" | |||
42 | LICENSE = "LGPLv2.1" | 42 | LICENSE = "LGPLv2.1" |
43 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1" | 43 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1" |
44 | 44 | ||
45 | DEPENDS = "libpcre attr acl popt file" | 45 | DEPENDS = "libpcre attr acl popt ossp-uuid file" |
46 | PR = "r40" | 46 | PR = "r41" |
47 | 47 | ||
48 | # rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed | 48 | # rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed |
49 | # in order to extract the distribution SRPM into a format we can extract... | 49 | # in order to extract the distribution SRPM into a format we can extract... |
@@ -69,6 +69,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.9-0.20120508.src.rpm;ex | |||
69 | file://rpm-no-perl-urpm.patch \ | 69 | file://rpm-no-perl-urpm.patch \ |
70 | file://rpm-macros.patch \ | 70 | file://rpm-macros.patch \ |
71 | file://rpm-lua.patch \ | 71 | file://rpm-lua.patch \ |
72 | file://rpm-ossp-uuid.patch \ | ||
72 | " | 73 | " |
73 | 74 | ||
74 | SRC_URI[md5sum] = "60d56ace884340c1b3fcac6a1d58e768" | 75 | SRC_URI[md5sum] = "60d56ace884340c1b3fcac6a1d58e768" |
@@ -145,7 +146,7 @@ EXTRA_OECONF += "--verbose \ | |||
145 | --without-gnutls \ | 146 | --without-gnutls \ |
146 | --with-pcre \ | 147 | --with-pcre \ |
147 | --enable-utf8 \ | 148 | --enable-utf8 \ |
148 | --without-uuid \ | 149 | --with-uuid \ |
149 | --with-attr \ | 150 | --with-attr \ |
150 | --with-acl \ | 151 | --with-acl \ |
151 | --with-popt=external \ | 152 | --with-popt=external \ |
@@ -330,6 +331,10 @@ do_configure() { | |||
330 | 331 | ||
331 | ./autogen.sh | 332 | ./autogen.sh |
332 | 333 | ||
334 | # NASTY hack to make sure configure files the right pkg-config file... | ||
335 | sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \ | ||
336 | -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i configure | ||
337 | |||
333 | export varprefix=${localstatedir} | 338 | export varprefix=${localstatedir} |
334 | export CC_FOR_BUILD="${BUILD_CC}" | 339 | export CC_FOR_BUILD="${BUILD_CC}" |
335 | oe_runconf | 340 | oe_runconf |