summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.9.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-06-11 13:18:53 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-12 11:10:35 +0100
commitbc4a29df84542f0ef905a2e20d8533a0ea7cb613 (patch)
treed0261f05a3ec020eb2c46dd36d22d1ee19be2a82 /meta/recipes-devtools/rpm/rpm_5.4.9.bb
parentb2381b63b94604fdc0e1a7591c854dc1df3ca8f4 (diff)
downloadpoky-bc4a29df84542f0ef905a2e20d8533a0ea7cb613.tar.gz
rpm: Upgrade RPM to 5.4.9
Beside upreving RPM, add necessary integration patches to libzypp. Also change the configuration of RPM to support PACKAGECONFIG flags. RPM is highly configurable, the default configuration is good for minimal OE-Core use. (From OE-Core rev: bf94103d4c532ffdfdcdcc6d27c9f65f7824f8f8) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.9.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb448
1 files changed, 448 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
new file mode 100644
index 0000000000..6eba802d8a
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -0,0 +1,448 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-libs = "Libraries for manipulating RPM packages."
9DESCRIPTION_${PN}-libs = "This package contains the RPM shared libraries."
10
11SUMMARY_${PN}-dev = "Development files for manipulating RPM packages."
12DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
13development files will simplify the process of writing programs that \
14manipulate RPM packages and databases. These files are intended to \
15simplify the process of creating graphical package managers or any \
16other tools that need an intimate knowledge of RPM packages in order \
17to function."
18
19SUMMARY_${PN}-common = "Common RPM paths, scripts, documentation and configuration."
20DESCRIPTION_${PN}-common = "The rpm-common package contains paths, scripts, documentation \
21and configuration common between RPM Package Manager."
22
23SUMMARY_${PN}-build = "Scripts and executable programs used to build packages."
24DESCRIPTION_${PN}-build = "The rpm-build packagec ontains the scripts and executable programs \
25that are used to build packages using the RPM Package Manager."
26
27SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages."
28DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
29written in the Python programming language to use the interface \
30supplied by the RPM Package Manager libraries."
31
32SUMMARY_perl-module-rpm = "Perl bindings for apps which will manipulate RPM packages."
33DESCRIPTION_perl-modules-rpm = "The perl-modules-rpm package contains a module that permits applications \
34written in the Perl programming language to use the interface \
35supplied by the RPM Package Manager libraries."
36
37SUMMARY_perl-module-rpm-dev = "Development components for perl bindings"
38DESCRIPTION_perl-modules-rpm-dev = "Development items such as man pages for use with the Perl \
39language bindings."
40
41HOMEPAGE = "http://rpm5.org/"
42LICENSE = "LGPLv2.1"
43LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
44
45DEPENDS = "libpcre attr acl popt file"
46PR = "r40"
47
48# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
49# in order to extract the distribution SRPM into a format we can extract...
50SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.9-0.20120508.src.rpm;extract=rpm-5.4.9.tar.gz \
51 file://rpm-log-auto-rm.patch \
52 file://rpm-db-reduce.patch \
53 file://perfile_rpmdeps.sh \
54 file://rpm-autogen.patch \
55 file://rpm-libsql-fix.patch \
56 file://header-include-fix.patch \
57 file://rpm-platform.patch \
58 file://rpm-showrc.patch \
59 file://rpm-solvedb.patch \
60 file://rpm-tools-mtree-LDFLAGS.patch \
61 file://rpm-fileclass.patch \
62 file://rpm-canonarch.patch \
63 file://rpm-no-loopmsg.patch \
64 file://rpm-scriptletexechelper.patch \
65 file://pythondeps.sh \
66 file://rpmdeps-oecore.patch \
67 file://rpm-resolvedep.patch \
68 file://rpm-respect-arch.patch \
69 file://rpm-no-perl-urpm.patch \
70 file://rpm-macros.patch \
71 file://rpm-lua.patch \
72 "
73
74SRC_URI[md5sum] = "60d56ace884340c1b3fcac6a1d58e768"
75SRC_URI[sha256sum] = "bac7cc5bd9d0e8262fdc0099349924608da8f680f5cb243751f696552239dde8"
76
77inherit autotools gettext
78
79acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
80
81# Specify the default rpm macros in terms of adjustable variables
82rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros"
83rpm_macros_virtclass-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
84
85# sqlite lua tcl augeas nss gcrypt neon xz xar keyutils perl selinux
86
87# Note: perl and sqlite w/o db specified does not currently work.
88# tcl, augeas, nss, gcrypt, xar and keyutils support is untested.
89PACKAGECONFIG_virtclass-native ??= "db bzip2 zlib beecrypt openssl libelf python"
90PACKAGECONFIG ??= "db bzip2 zlib beecrypt openssl libelf python"
91
92PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2,"
93PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz,"
94PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
95PACKAGECONFIG[xar] = "--with-xar,--without-xar,xar,"
96
97WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \
98 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
99 --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION} \
100 --without-pythonembed"
101PACKAGECONFIG[python] = "${WITH_PYTHON},--without-python,python,"
102
103# Perl modules are not built, but they could be enabled fairly easily
104# the perl module creation and installation would need to be patched.
105# (currently has host perl contamination issues)
106WITH_PERL = "--with-perl --without-perlembed --without-perl-urpm"
107WITHOUT_PERL = "--without-perl --without-perl-urpm"
108PACKAGECONFIG[perl] = "${WITH_PERL},${WITHOUT_PERL},perl,"
109
110# The --with-dbsql will only tell RPM to check for support, db
111# may or may not be built w/ the dbsql support.
112WITH_DB = "--with-db --with-dbsql --without-db-tools-integrated"
113PACKAGECONFIG[db] = "${WITH_DB},--without-db,db,"
114
115PACKAGECONFIG[sqlite] = "--with-sqlite,--without-sqlite,sqlite3,"
116
117PACKAGECONFIG[beecrypt] = "--with-beecrypt,--without-beecrypt,beecrypt,"
118PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
119PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss,"
120PACKAGECONFIG[gcrypt] = "--with-gcrypt,--without-gcrypt,gcrypt,"
121PACKAGECONFIG[keyutils] = "--with-keyutils,--without-keyutils,keyutils,"
122PACKAGECONFIG[libelf] = "--with-libelf,--without-libelf,elfutils,"
123
124WITH_SELINUX = "--with-selinux --with-sepol --with-semanage"
125WITHOUT_SELINUX = "--without-selinux --without-sepol --without-semanage"
126PACKAGECONFIG[selinux] = "${WITH_SELINUX},${WITHOUT_SELINUX},selinux,"
127
128WITH_NEON = "--with-neon --with-libproxy --with-expat --without-gssapi"
129WITHOUT_NEON = "--without-neon --without-libproxy --without-expat --without-gssapi"
130PACKAGECONFIG[neon] = "${WITH_NEON},${WITHOUT_NEON},neon,"
131
132PACKAGECONFIG[lua] = "--with-lua,--without-lua,"
133PACKAGECONFIG[tcl] = "--with-tcl,--without-tcl,tcl,"
134
135PACAKGECONFIG[augeas] = "--with-augeas,--without-augeas,augeas,"
136
137EXTRA_OECONF += "--verbose \
138 --sysconfdir=/etc \
139 --with-file \
140 --with-path-magic=%{_usrlibrpm}/../../share/misc/magic.mgc \
141 --with-syck=internal \
142 --without-readline \
143 --without-libtasn1 \
144 --without-pakchois \
145 --without-gnutls \
146 --with-pcre \
147 --enable-utf8 \
148 --without-uuid \
149 --with-attr \
150 --with-acl \
151 --with-popt=external \
152 --with-pthreads \
153 --without-cudf \
154 --without-ficl \
155 --without-aterm \
156 --without-nix \
157 --without-bash \
158 --without-rc \
159 --without-js \
160 --without-gpsee \
161 --without-ruby \
162 --without-squirrel \
163 --with-build-extlibdep \
164 --with-build-maxextlibdep \
165 --without-valgrind \
166 --disable-openmp \
167 --enable-build-pic \
168 --enable-build-versionscript \
169 --enable-build-warnings \
170 --enable-build-debug \
171 --enable-maintainer-mode \
172 --with-path-macros=${rpm_macros} \
173 --with-path-lib=${libdir}/rpm \
174 --with-bugreport=http://bugzilla.yoctoproject.org \
175 --program-prefix="
176
177CFLAGS_append = " -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY -DRPM_VENDOR_OE"
178
179PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-libs ${PN}-dev ${PN}-staticdev ${PN}-common ${PN}-build python-rpm-dbg python-rpm-staticdev python-rpm perl-module-rpm perl-module-rpm-dev ${PN}-locale"
180
181SOLIBS = "5.4.so"
182
183# Based on %files section in the rpm.spec
184
185FILES_${PN} = "${bindir}/rpm \
186 ${bindir}/rpmconstant \
187 ${libdir}/rpm/rpm.* \
188 ${libdir}/rpm/tgpg \
189 ${libdir}/rpm/macros \
190 ${libdir}/rpm/rpmpopt \
191 ${libdir}/rpm/rpmdb_loadcvt \
192 ${libdir}/rpm/rpm2cpio \
193 ${libdir}/rpm/vcheck \
194 ${libdir}/rpm/helpers \
195 ${libdir}/rpm/qf \
196 ${libdir}/rpm/cpuinfo.yaml \
197 ${libdir}/rpm/bin/mtree \
198 ${libdir}/rpm/bin/rpmkey \
199 ${libdir}/rpm/bin/rpmrepo \
200 ${libdir}/rpm/bin/rpmspecdump \
201 ${libdir}/rpm/bin/wget \
202 /var/lib/rpm \
203 /var/cache/rpm \
204 /var/volatile/cache/rpm \
205 "
206
207FILES_${PN}-dbg += "${libdir}/rpm/.debug \
208 ${libdir}/rpm/bin/.debug \
209 "
210
211FILES_${PN}-common = "${bindir}/rpm2cpio \
212 ${bindir}/gendiff \
213 /etc/rpm \
214 /var/spool/repackage \
215 "
216
217FILES_${PN}-libs = "${libdir}/librpm-*.so \
218 ${libdir}/librpmconstant-*.so \
219 ${libdir}/librpmdb-*.so \
220 ${libdir}/librpmio-*.so \
221 ${libdir}/librpmmisc-*.so \
222 ${libdir}/librpmbuild-*.so \
223 "
224
225FILES_${PN}-build = "${prefix}/src/rpm \
226 ${bindir}/rpmbuild \
227 ${libdir}/rpm/brp-* \
228 ${libdir}/rpm/check-files \
229 ${libdir}/rpm/cross-build \
230 ${libdir}/rpm/find-debuginfo.sh \
231 ${libdir}/rpm/find-lang.sh \
232 ${libdir}/rpm/find-prov.pl \
233 ${libdir}/rpm/find-provides.perl \
234 ${libdir}/rpm/find-req.pl \
235 ${libdir}/rpm/find-requires.perl \
236 ${libdir}/rpm/getpo.sh \
237 ${libdir}/rpm/http.req \
238 ${libdir}/rpm/javadeps.sh \
239 ${libdir}/rpm/mono-find-provides \
240 ${libdir}/rpm/mono-find-requires \
241 ${libdir}/rpm/executabledeps.sh \
242 ${libdir}/rpm/libtooldeps.sh \
243 ${libdir}/rpm/osgideps.pl \
244 ${libdir}/rpm/perldeps.pl \
245 ${libdir}/rpm/perl.prov \
246 ${libdir}/rpm/perl.req \
247 ${libdir}/rpm/php.prov \
248 ${libdir}/rpm/php.req \
249 ${libdir}/rpm/pkgconfigdeps.sh \
250 ${libdir}/rpm/pythondeps.sh \
251 ${libdir}/rpm/bin/debugedit \
252 ${libdir}/rpm/bin/rpmcache \
253 ${libdir}/rpm/bin/rpmcmp \
254 ${libdir}/rpm/bin/rpmdeps \
255 ${libdir}/rpm/bin/rpmdeps-oecore \
256 ${libdir}/rpm/bin/rpmdigest \
257 ${libdir}/rpm/bin/abi-compliance-checker.pl \
258 ${libdir}/rpm/bin/api-sanity-autotest.pl \
259 ${libdir}/rpm/bin/chroot \
260 ${libdir}/rpm/bin/cp \
261 ${libdir}/rpm/bin/dbsql \
262 ${libdir}/rpm/bin/find \
263 ${libdir}/rpm/bin/install-sh \
264 ${libdir}/rpm/bin/lua \
265 ${libdir}/rpm/bin/luac \
266 ${libdir}/rpm/bin/mkinstalldirs \
267 ${libdir}/rpm/bin/rpmlua \
268 ${libdir}/rpm/bin/rpmluac \
269 ${libdir}/rpm/bin/sqlite3 \
270 ${libdir}/rpm/macros.d/cmake \
271 ${libdir}/rpm/macros.d/java \
272 ${libdir}/rpm/macros.d/libtool \
273 ${libdir}/rpm/macros.d/mandriva \
274 ${libdir}/rpm/macros.d/mono \
275 ${libdir}/rpm/macros.d/perl \
276 ${libdir}/rpm/macros.d/php \
277 ${libdir}/rpm/macros.d/pkgconfig \
278 ${libdir}/rpm/macros.d/python \
279 ${libdir}/rpm/macros.d/ruby \
280 ${libdir}/rpm/macros.d/selinux \
281 ${libdir}/rpm/macros.d/tcl \
282 ${libdir}/rpm/macros.rpmbuild \
283 ${libdir}/rpm/u_pkg.sh \
284 ${libdir}/rpm/vpkg-provides.sh \
285 ${libdir}/rpm/vpkg-provides2.sh \
286 ${libdir}/rpm/perfile_rpmdeps.sh \
287 "
288RDEPENDS_${PN}-build = "file"
289
290FILES_python-rpm-dbg = "${libdir}/python*/rpm/.debug/_*"
291FILES_python-rpm-staticdev = "${libdir}/python*/rpm/*.a"
292FILES_python-rpm = "${libdir}/python*/rpm"
293
294FILES_perl-module-rpm = "${libdir}/perl/*/* \
295 "
296
297FILES_perl-module-rpm-dev = "${prefix}/share/man/man3/RPM* \
298 "
299
300FILES_${PN}-dev = "${includedir}/rpm \
301 ${libdir}/librpm.la \
302 ${libdir}/librpm.so \
303 ${libdir}/librpmconstant.la \
304 ${libdir}/librpmconstant.so \
305 ${libdir}/librpmdb.la \
306 ${libdir}/librpmdb.so \
307 ${libdir}/librpmio.la \
308 ${libdir}/librpmio.so \
309 ${libdir}/librpmmisc.la \
310 ${libdir}/librpmmisc.so \
311 ${libdir}/librpmbuild.la \
312 ${libdir}/librpmbuild.so \
313 ${libdir}/rpm/lib/liblua.la \
314 ${libdir}/pkgconfig/rpm.pc \
315 "
316
317FILES_${PN}-staticdev = " \
318 ${libdir}/librpm.a \
319 ${libdir}/librpmconstant.a \
320 ${libdir}/librpmdb.a \
321 ${libdir}/librpmio.a \
322 ${libdir}/librpmmisc.a \
323 ${libdir}/librpmbuild.a \
324 ${libdir}/rpm/lib/liblua.a \
325 "
326
327do_configure() {
328 # Disable tests!
329 echo "all:" > tests/Makefile.am
330
331 ./autogen.sh
332
333 export varprefix=${localstatedir}
334 export CC_FOR_BUILD="${BUILD_CC}"
335 oe_runconf
336}
337
338do_install_append() {
339 sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
340 sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
341 sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros
342 sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros
343 sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros
344
345 # Enable Debian style arbitrary tags...
346 sed -i -e 's,%_arbitrary_tags[^_].*,%_arbitrary_tags %{_arbitrary_tags_debian},' ${D}/${libdir}/rpm/macros
347
348 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
349 install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh
350
351 # Remove unpackaged files (based on list in rpm.spec)
352 rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm}
353
354 rm -f ${D}/${mandir}/man8/rpmcache.8*
355 rm -f ${D}/${mandir}/man8/rpmgraph.8*
356 rm -f ${D}/${mandir}/*/man8/rpmcache.8*
357 rm -f ${D}/${mandir}/*/man8/rpmgraph.8*
358 rm -rf ${D}/${mandir}/{fr,ko}
359
360 rm -f ${D}/${includedir}/popt.h
361 rm -f ${D}/${libdir}/libpopt.*
362 rm -f ${D}/${libdir}/pkgconfig/popt.pc
363 rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo
364 rm -f ${D}/${mandir}/man3/popt.3
365
366 rm -f ${D}/${mandir}/man1/xar.1*
367 rm -f ${D}/${bindir}/xar
368 rm -rf ${D}/${includedir}/xar
369 rm -f ${D}/${libdir}/libxar*
370
371 rm -f ${D}/${bindir}/lz*
372 rm -f ${D}/${bindir}/unlzma
373 rm -f ${D}/${bindir}/unxz
374 rm -f ${D}/${bindir}/xz*
375 rm -rf ${D}/${includedir}/lzma*
376 rm -f ${D}/${mandir}/man1/lz*.1
377 rm -f ${D}/${libdir}/pkgconfig/liblzma*
378
379 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
380 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
381
382 #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
383 # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
384 #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
385
386 # We don't want the default macro set
387 rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*}
388
389 rm -f ${D}/${libdir}/rpm/dbconvert.sh
390
391 rm -f ${D}/${libdir}/rpm/libsqldb.*
392
393 # We don't want, nor need the Mandriva multiarch items
394 rm -f ${D}/${bindir}/multiarch-dispatch
395 rm -f ${D}/${bindir}/multiarch-platform
396 rm -f ${D}/${libdir}/rpm/check-multiarch-files
397 rm -f ${D}/${libdir}/rpm/mkmultiarch
398 rm -f ${D}/${includedir}/multiarch-dispatch.h
399
400 rm -f ${D}/${libdir}/rpm/gstreamer.sh
401 rm -f ${D}/${libdir}/rpm/gem_helper.rb
402 rm -f ${D}/${libdir}/rpm/rubygems.rb
403 rm -f ${D}/${libdir}/rpm/kmod-deps.sh
404 rm -f ${D}/${libdir}/rpm/pythoneggs.py
405 rm -f ${D}/${libdir}/rpm/macros.d/kernel
406 rm -f ${D}/${libdir}/rpm/macros.d/gstreamer
407 rm -f ${D}/${libdir}/rpm/bin/mgo
408 rm -f ${D}/${libdir}/rpm/bin/dbconvert
409 rm -f ${D}/${libdir}/rpm/bin/pom2spec
410
411 rm -rf ${D}/var/lib/wdj ${D}/var/cache/wdj
412 rm -f ${D}/usr/lib/rpm/bin/api-sanity-checker.pl
413}
414
415do_install_append_virtclass-native() {
416 create_wrapper ${D}/${bindir}/rpm \
417 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
418 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
419 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
420
421 create_wrapper ${D}/${bindir}/rpm2cpio \
422 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
423 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
424 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
425
426 create_wrapper ${D}/${bindir}/rpmbuild \
427 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
428 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
429 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
430
431 create_wrapper ${D}/${bindir}/rpmconstant \
432 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
433 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
434 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
435
436 for rpm_binary in ${D}/${libdir}/rpm/bin/rpm*; do
437 create_wrapper $rpm_binary
438 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
439 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
440 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
441 done
442
443 # Adjust popt macros to match...
444 cat ${D}/${libdir}/rpm/rpmpopt | sed -e "s,^\(rpm[^ ]*\)\([ ]\),\1.real\2," > ${D}/${libdir}/rpm/rpmpopt.new
445 mv ${D}/${libdir}/rpm/rpmpopt.new ${D}/${libdir}/rpm/rpmpopt
446}
447
448BBCLASSEXTEND = "native"