diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2016-07-17 20:32:41 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-07-26 08:56:28 +0100 |
commit | 51b08835b64421669e018481e344effe4727183b (patch) | |
tree | 27945804000e9c536e78e037798793361b200fb0 /meta/recipes-devtools/rpm/rpm_5.4.16.bb | |
parent | 2ab49268fd370d68401891870296fed56016fd90 (diff) | |
download | poky-51b08835b64421669e018481e344effe4727183b.tar.gz |
rpm: make --nosignature work
OE-core uses rpm's --nosignature, but it never worked:
self._invoke_smart('config --set rpm-check-signatures=false')
Now fix it with:
* Define SUPPORT_NOSIGNATURES to 1 in system.h
* !QVA_ISSET(qva->qva_flags, SIGNATURE) -> QVA_ISSET(qva->qva_flags, SIGNATURE),
otherwise, when use --nosignature would read database and verify
signature, this is not expected.
This can fix some race issues, for example, when more than one process
are querying rpm file with "rpm -qp --nosignature", they may hang up
because of race issues (the processes are trying to get RW/RD lock on
the database, but they shouldn't read the database at all since -qp and
--nosignature are used).
(From OE-Core rev: 038c09d6ab9581030efdc16aa1b96972970eeaab)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.16.bb')
-rw-r--r-- | meta/recipes-devtools/rpm/rpm_5.4.16.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.16.bb b/meta/recipes-devtools/rpm/rpm_5.4.16.bb index 3adb29c347..d264d5011a 100644 --- a/meta/recipes-devtools/rpm/rpm_5.4.16.bb +++ b/meta/recipes-devtools/rpm/rpm_5.4.16.bb | |||
@@ -117,6 +117,7 @@ SRC_URI += " \ | |||
117 | file://rpmqv.c-check-_gpg_passphrase-before-ask-for-input.patch \ | 117 | file://rpmqv.c-check-_gpg_passphrase-before-ask-for-input.patch \ |
118 | file://0001-Disable-__sync_add_and_fetch_8-on-nios2.patch \ | 118 | file://0001-Disable-__sync_add_and_fetch_8-on-nios2.patch \ |
119 | file://gcc6-stdlib.patch \ | 119 | file://gcc6-stdlib.patch \ |
120 | file://0001-system.h-query.c-support-nosignature.patch \ | ||
120 | " | 121 | " |
121 | 122 | ||
122 | # OE specific changes | 123 | # OE specific changes |