diff options
author | Chen Qi <Qi.Chen@windriver.com> | 2016-11-15 14:31:06 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-11-23 11:10:14 +0000 |
commit | 43a135b0c8f9f9ab2f48f739ab134390e862c0cc (patch) | |
tree | 48e848c2983e6991ec6dd15f78a61c98815dc663 /meta/recipes-devtools/rpm/rpm_5.4.16.bb | |
parent | 40c07e10415cdeccdbc8d8c49c7cf468f1ba0c04 (diff) | |
download | poky-43a135b0c8f9f9ab2f48f739ab134390e862c0cc.tar.gz |
rpm: fix multilib macro installation
For now, the rpm macro for multilib is not installed correctly. For
example, in x86-64 lib32 situation, the macro is installed under
tmp/work/x86-pokymllib32-linux/rpm/5.4.16-r0/image/usr/lib/rpm/poky/i686-linux/.
The directory is even not under WORKDIR. And it will of course not be
packaged.
We need to save necessary values before updating the localdata and restore
them so that the macros could be installed into the correct directory.
(From OE-Core rev: 40e92de46489bdab0af48fedc46c0d153355f15c)
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.16.bb')
-rw-r--r-- | meta/recipes-devtools/rpm/rpm_5.4.16.bb | 8 |
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.16.bb b/meta/recipes-devtools/rpm/rpm_5.4.16.bb index 85eb5fef1e..182818ee09 100644 --- a/meta/recipes-devtools/rpm/rpm_5.4.16.bb +++ b/meta/recipes-devtools/rpm/rpm_5.4.16.bb | |||
@@ -626,8 +626,9 @@ def multilib_rpmmacros(d): | |||
626 | localdata.delVar('TOOLCHAIN_OPTIONS') | 626 | localdata.delVar('TOOLCHAIN_OPTIONS') |
627 | 627 | ||
628 | # Set 'localdata' values to be consistent with 'd' values. | 628 | # Set 'localdata' values to be consistent with 'd' values. |
629 | localdata.setVar('distromacrodir', d.getVar('distromacrodir', True)) | 629 | distromacrodirVal = d.getVar('distromacrodir', True) |
630 | localdata.setVar('WORKDIR', d.getVar('WORKDIR', True)) | 630 | workdirVal = d.getVar('WORKDIR', True) |
631 | dval = d.getVar('D', True) | ||
631 | 632 | ||
632 | ret = gen_arch_macro(localdata) | 633 | ret = gen_arch_macro(localdata) |
633 | 634 | ||
@@ -639,6 +640,9 @@ def multilib_rpmmacros(d): | |||
639 | localdata.setVar("OVERRIDES", overrides) | 640 | localdata.setVar("OVERRIDES", overrides) |
640 | localdata.setVar("MLPREFIX", item + "-") | 641 | localdata.setVar("MLPREFIX", item + "-") |
641 | bb.data.update_data(localdata) | 642 | bb.data.update_data(localdata) |
643 | localdata.setVar('WORKDIR', workdirVal) | ||
644 | localdata.setVar('distromacrodir', distromacrodirVal) | ||
645 | localdata.setVar('D', dval) | ||
642 | ret += gen_arch_macro(localdata) | 646 | ret += gen_arch_macro(localdata) |
643 | return ret | 647 | return ret |
644 | 648 | ||