diff options
author | Ross Burton <ross.burton@intel.com> | 2016-09-08 17:18:18 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-09-14 22:22:07 +0100 |
commit | 03fa8209e4ebcf16b2bdf4038e26db31b14e9de0 (patch) | |
tree | 6b7610692015c9efb4a8d7a164b61fc6b6b0efb2 /meta/recipes-devtools/rpm/rpm_5.4.16.bb | |
parent | 059c5568a130f82f8612498487e49f231247b4a5 (diff) | |
download | poky-03fa8209e4ebcf16b2bdf4038e26db31b14e9de0.tar.gz |
rpm: remove redundant removals
These were noticed by the use of bashisms (rm *.{foo,bar}) and lots of these rm
commands are deleting files which don't exist in the first place.
(From OE-Core rev: 52182efe70a8fb59b5640cd1cf2bdb55e77c0076)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.16.bb')
-rw-r--r-- | meta/recipes-devtools/rpm/rpm_5.4.16.bb | 36 |
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.16.bb b/meta/recipes-devtools/rpm/rpm_5.4.16.bb index 9f78deeea2..dd6e103b22 100644 --- a/meta/recipes-devtools/rpm/rpm_5.4.16.bb +++ b/meta/recipes-devtools/rpm/rpm_5.4.16.bb | |||
@@ -554,54 +554,20 @@ do_install_append() { | |||
554 | install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh | 554 | install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh |
555 | install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh | 555 | install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh |
556 | 556 | ||
557 | # Remove unpackaged files (based on list in rpm.spec) | ||
558 | rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm} | ||
559 | |||
560 | rm -f ${D}/${mandir}/man8/rpmcache.8* | ||
561 | rm -f ${D}/${mandir}/man8/rpmgraph.8* | ||
562 | rm -f ${D}/${mandir}/*/man8/rpmcache.8* | ||
563 | rm -f ${D}/${mandir}/*/man8/rpmgraph.8* | ||
564 | rm -rf ${D}/${mandir}/{fr,ko} | ||
565 | |||
566 | rm -f ${D}/${includedir}/popt.h | 557 | rm -f ${D}/${includedir}/popt.h |
567 | rm -f ${D}/${libdir}/libpopt.* | 558 | rm -f ${D}/${libdir}/libpopt.* |
568 | rm -f ${D}/${libdir}/pkgconfig/popt.pc | 559 | rm -f ${D}/${libdir}/pkgconfig/popt.pc |
569 | rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo | 560 | rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo |
570 | rm -f ${D}/${mandir}/man3/popt.3 | 561 | rm -f ${D}/${mandir}/man3/popt.3 |
571 | 562 | ||
572 | rm -f ${D}/${mandir}/man1/xar.1* | ||
573 | rm -f ${D}/${bindir}/xar | ||
574 | rm -rf ${D}/${includedir}/xar | ||
575 | rm -f ${D}/${libdir}/libxar* | ||
576 | |||
577 | rm -f ${D}/${bindir}/lz* | ||
578 | rm -f ${D}/${bindir}/unlzma | ||
579 | rm -f ${D}/${bindir}/unxz | ||
580 | rm -f ${D}/${bindir}/xz* | ||
581 | rm -rf ${D}/${includedir}/lzma* | ||
582 | rm -f ${D}/${mandir}/man1/lz*.1 | ||
583 | rm -f ${D}/${libdir}/pkgconfig/liblzma* | ||
584 | |||
585 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/*.a | 563 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/*.a |
586 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/*.la | 564 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/*.la |
587 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/*.a | 565 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/*.a |
588 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/*.la | 566 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/*.la |
589 | 567 | ||
590 | #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \ | ||
591 | # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';' | ||
592 | #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';' | ||
593 | |||
594 | rm -f ${D}/${libdir}/rpm/dbconvert.sh | 568 | rm -f ${D}/${libdir}/rpm/dbconvert.sh |
595 | |||
596 | rm -f ${D}/${libdir}/rpm/libsqldb.* | 569 | rm -f ${D}/${libdir}/rpm/libsqldb.* |
597 | 570 | ||
598 | # We don't want, nor need the Mandriva multiarch items | ||
599 | rm -f ${D}/${bindir}/multiarch-dispatch | ||
600 | rm -f ${D}/${bindir}/multiarch-platform | ||
601 | rm -f ${D}/${libdir}/rpm/check-multiarch-files | ||
602 | rm -f ${D}/${libdir}/rpm/mkmultiarch | ||
603 | rm -f ${D}/${includedir}/multiarch-dispatch.h | ||
604 | |||
605 | rm -f ${D}/${libdir}/rpm/gstreamer.sh | 571 | rm -f ${D}/${libdir}/rpm/gstreamer.sh |
606 | rm -f ${D}/${libdir}/rpm/gem_helper.rb | 572 | rm -f ${D}/${libdir}/rpm/gem_helper.rb |
607 | rm -f ${D}/${libdir}/rpm/rubygems.rb | 573 | rm -f ${D}/${libdir}/rpm/rubygems.rb |
@@ -610,12 +576,10 @@ do_install_append() { | |||
610 | rm -f ${D}/${libdir}/rpm/macros.d/kernel | 576 | rm -f ${D}/${libdir}/rpm/macros.d/kernel |
611 | rm -f ${D}/${libdir}/rpm/macros.d/gstreamer | 577 | rm -f ${D}/${libdir}/rpm/macros.d/gstreamer |
612 | rm -f ${D}/${libdir}/rpm/bin/mgo | 578 | rm -f ${D}/${libdir}/rpm/bin/mgo |
613 | rm -f ${D}/${libdir}/rpm/bin/dbconvert | ||
614 | rm -f ${D}/${libdir}/rpm/bin/pom2spec | 579 | rm -f ${D}/${libdir}/rpm/bin/pom2spec |
615 | 580 | ||
616 | rm -rf ${D}/var/lib/wdj ${D}/var/cache/wdj | 581 | rm -rf ${D}/var/lib/wdj ${D}/var/cache/wdj |
617 | rm -f ${D}/${libdir}/rpm/bin/api-sanity-checker.pl | 582 | rm -f ${D}/${libdir}/rpm/bin/api-sanity-checker.pl |
618 | |||
619 | } | 583 | } |
620 | 584 | ||
621 | do_install_append_class-target() { | 585 | do_install_append_class-target() { |