summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.14.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2014-07-02 19:57:44 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-08 11:20:12 +0100
commitfe483ca37c33ebfe4c3e391244c47969e1560aeb (patch)
tree4b703d42ad5b4c22f9075463c013e562ab649345 /meta/recipes-devtools/rpm/rpm_5.4.14.bb
parent107ef516a6b5dc8f6e4606d30e8fa204d75f0b21 (diff)
downloadpoky-fe483ca37c33ebfe4c3e391244c47969e1560aeb.tar.gz
rpm: Upgrade to 5.4.14
Update various patches. A few corrections to the patch descriptions, otherwise simple quilt refresh or conflict resolution. Remove rpm-solvedb.patch and rpm-respect-arch.patch. These are both related to the old solvedb package dependency solver. This is no longer used since we moved to smartpm. rpm-stub-out-git_strerror was a backport and is no longer needed. RPM 5.4.12 and newer normally requires Berkley DB 6.0 or newer. A small patch to configure allows RPM to dynamically select DB 5.3 or DB 6.0 based on what is available at configure time. (From OE-Core rev: 0c7b4a5e23836889196f85f472f081d51529e94e) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.14.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.14.bb515
1 files changed, 515 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.14.bb b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
new file mode 100644
index 0000000000..e1c6abb3d8
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
@@ -0,0 +1,515 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-libs = "Libraries for manipulating RPM packages"
9DESCRIPTION_${PN}-libs = "This package contains the RPM shared libraries."
10
11SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
12DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
13development files will simplify the process of writing programs that \
14manipulate RPM packages and databases. These files are intended to \
15simplify the process of creating graphical package managers or any \
16other tools that need an intimate knowledge of RPM packages in order \
17to function."
18
19SUMMARY_${PN}-common = "Common RPM paths, scripts, documentation and configuration"
20DESCRIPTION_${PN}-common = "The rpm-common package contains paths, scripts, documentation \
21and configuration common between RPM Package Manager."
22
23SUMMARY_${PN}-build = "Scripts and executable programs used to build packages"
24DESCRIPTION_${PN}-build = "The rpm-build packagec ontains the scripts and executable programs \
25that are used to build packages using the RPM Package Manager."
26
27SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages"
28DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
29written in the Python programming language to use the interface \
30supplied by the RPM Package Manager libraries."
31
32SUMMARY_perl-module-rpm = "Perl bindings for apps which will manipulate RPM packages"
33DESCRIPTION_perl-modules-rpm = "The perl-modules-rpm package contains a module that permits applications \
34written in the Perl programming language to use the interface \
35supplied by the RPM Package Manager libraries."
36
37SUMMARY_perl-module-rpm-dev = "Development components for perl bindings"
38DESCRIPTION_perl-modules-rpm-dev = "Development items such as man pages for use with the Perl \
39language bindings."
40
41HOMEPAGE = "http://rpm5.org/"
42LICENSE = "LGPLv2.1"
43LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
44
45DEPENDS = "libpcre attr acl popt ossp-uuid file byacc-native"
46
47# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
48# in order to extract the distribution SRPM into a format we can extract...
49SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.14-0.20131024.src.rpm;extract=rpm-5.4.14.tar.gz \
50 file://rpm-log-auto-rm.patch \
51 file://rpm-db-reduce.patch \
52 file://perfile_rpmdeps.sh \
53 file://rpm-autogen.patch \
54 file://rpm-libsql-fix.patch \
55 file://header-include-fix.patch \
56 file://rpm-platform.patch \
57 file://rpm-showrc.patch \
58 file://rpm-tools-mtree-LDFLAGS.patch \
59 file://rpm-fileclass.patch \
60 file://rpm-canonarch.patch \
61 file://rpm-no-loopmsg.patch \
62 file://rpm-scriptletexechelper.patch \
63 file://pythondeps.sh \
64 file://rpmdeps-oecore.patch \
65 file://rpm-resolvedep.patch \
66 file://rpm-no-perl-urpm.patch \
67 file://rpm-macros.patch \
68 file://rpm-lua.patch \
69 file://rpm-ossp-uuid.patch \
70 file://rpm-packageorigin.patch \
71 file://rpm-pkgconfigdeps.patch \
72 file://uclibc-support.patch \
73 file://rpmatch.patch \
74 file://fstack-protector-configure-check.patch \
75 file://dbconvert.patch \
76 file://rpm-uuid-include.patch \
77 file://makefile-am-exec-hook.patch \
78 file://rpm-db_buffer_small.patch \
79 file://rpm-py-init.patch \
80 file://python-rpm-rpmsense.patch \
81 file://rpm-reloc-macros.patch \
82 file://rpm-platform2.patch \
83 file://rpm-remove-sykcparse-decl.patch \
84 file://debugedit-segv.patch \
85 file://debugedit-valid-file-to-fix-segment-fault.patch \
86 file://rpm-platform-file-fix.patch \
87 file://rpm-lsb-compatibility.patch \
88 file://rpm-tag-generate-endian-conversion-fix.patch \
89 file://rpm-verify-files.patch \
90 file://rpm-hardlink-segfault-fix.patch \
91 file://rpm-payload-use-hashed-inode.patch \
92 file://rpm-fix-logio-cp.patch \
93 file://rpm-db5-or-db6.patch \
94 "
95
96# Uncomment the following line to enable platform score debugging
97# This is useful when identifying issues with Smart being unable
98# to process certain package feeds.
99#SRC_URI += "file://rpm-debug-platform.patch"
100
101SRC_URI[md5sum] = "25093d399a0b5d1342d24900a91b347d"
102SRC_URI[sha256sum] = "676e3ab41f72e3b504e04109cfb565a300742f56a7da084f202013b30eeae467"
103
104inherit autotools gettext
105
106acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
107
108# Specify the default rpm macros in terms of adjustable variables
109rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros"
110rpm_macros_class-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
111rpm_macros_class-nativesdk = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
112
113# sqlite lua tcl augeas nss gcrypt neon xz xar keyutils perl selinux
114
115# Note: perl and sqlite w/o db specified does not currently work.
116# tcl, augeas, nss, gcrypt, xar and keyutils support is untested.
117PACKAGECONFIG ??= "db bzip2 zlib beecrypt openssl libelf python"
118
119PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2,"
120PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz,"
121PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
122PACKAGECONFIG[xar] = "--with-xar,--without-xar,xar,"
123
124WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \
125 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
126 --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION}/site-packages \
127 --without-pythonembed"
128PACKAGECONFIG[python] = "${WITH_PYTHON},--without-python,python,"
129
130# Perl modules are not built, but they could be enabled fairly easily
131# the perl module creation and installation would need to be patched.
132# (currently has host perl contamination issues)
133WITH_PERL = "--with-perl --without-perlembed --without-perl-urpm"
134WITHOUT_PERL = "--without-perl --without-perl-urpm"
135PACKAGECONFIG[perl] = "${WITH_PERL},${WITHOUT_PERL},perl,"
136
137# The --with-dbsql will only tell RPM to check for support, db
138# may or may not be built w/ the dbsql support.
139WITH_DB = "--with-db --with-dbsql --without-db-tools-integrated"
140PACKAGECONFIG[db] = "${WITH_DB},--without-db,db,"
141
142PACKAGECONFIG[sqlite] = "--with-sqlite,--without-sqlite,sqlite3,"
143
144PACKAGECONFIG[beecrypt] = "--with-beecrypt=external,--without-beecrypt,beecrypt,"
145PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
146PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss,"
147PACKAGECONFIG[gcrypt] = "--with-gcrypt,--without-gcrypt,gcrypt,"
148PACKAGECONFIG[keyutils] = "--with-keyutils,--without-keyutils,keyutils,"
149PACKAGECONFIG[libelf] = "--with-libelf,--without-libelf,elfutils,"
150
151WITH_SELINUX = "--with-selinux --with-sepol --with-semanage"
152WITHOUT_SELINUX = "--without-selinux --without-sepol --without-semanage"
153PACKAGECONFIG[selinux] = "${WITH_SELINUX},${WITHOUT_SELINUX},libselinux,"
154
155WITH_NEON = "--with-neon --with-libproxy --with-expat --without-gssapi"
156WITHOUT_NEON = "--without-neon --without-libproxy --without-expat --without-gssapi"
157PACKAGECONFIG[neon] = "${WITH_NEON},${WITHOUT_NEON},neon expat,"
158
159PACKAGECONFIG[lua] = "--with-lua,--without-lua,expat,"
160PACKAGECONFIG[tcl] = "--with-tcl,--without-tcl,tcl,"
161
162PACKAGECONFIG[augeas] = "--with-augeas,--without-augeas,augeas,"
163
164EXTRA_OECONF += "--verbose \
165 --sysconfdir=${sysconfdir} \
166 --with-file \
167 --with-path-magic=%{_usrlibrpm}/../../share/misc/magic.mgc \
168 --with-syck=internal \
169 --without-readline \
170 --without-libtasn1 \
171 --without-pakchois \
172 --without-gnutls \
173 --with-pcre \
174 --enable-utf8 \
175 --with-uuid \
176 --with-attr \
177 --with-acl \
178 --with-popt=external \
179 --with-pthreads \
180 --without-cudf \
181 --without-ficl \
182 --without-aterm \
183 --without-nix \
184 --without-bash \
185 --without-rc \
186 --without-js \
187 --without-gpsee \
188 --without-ruby \
189 --without-squirrel \
190 --with-build-extlibdep \
191 --with-build-maxextlibdep \
192 --without-valgrind \
193 --disable-openmp \
194 --enable-build-pic \
195 --enable-build-versionscript \
196 --enable-build-warnings \
197 --enable-build-debug \
198 --enable-maintainer-mode \
199 --with-path-macros=${rpm_macros} \
200 --with-path-lib=${libdir}/rpm \
201 --with-bugreport=http://bugzilla.yoctoproject.org \
202 --program-prefix= \
203 YACC=byacc"
204
205CFLAGS_append = " -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY -DRPM_VENDOR_OE"
206
207LDFLAGS_append_libc-uclibc = "-lrt -lpthread"
208
209PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-libs ${PN}-dev ${PN}-staticdev ${PN}-common ${PN}-build python-rpm-dbg python-rpm-staticdev python-rpm-dev python-rpm perl-module-rpm perl-module-rpm-dev ${PN}-locale"
210
211SOLIBS = "5.4.so"
212
213# Based on %files section in the rpm.spec
214
215FILES_${PN} = "${bindir}/rpm \
216 ${bindir}/rpmconstant \
217 ${libdir}/rpm/rpm.* \
218 ${libdir}/rpm/tgpg \
219 ${libdir}/rpm/macros \
220 ${libdir}/rpm/rpmpopt \
221 ${libdir}/rpm/rpm2cpio \
222 ${libdir}/rpm/vcheck \
223 ${libdir}/rpm/helpers \
224 ${libdir}/rpm/qf \
225 ${libdir}/rpm/cpuinfo.yaml \
226 ${libdir}/rpm/bin/mtree \
227 ${libdir}/rpm/bin/rpmkey \
228 ${libdir}/rpm/bin/rpmrepo \
229 ${libdir}/rpm/bin/rpmrepo.real \
230 ${libdir}/rpm/bin/rpmspecdump \
231 ${libdir}/rpm/bin/rpmspecdump.real \
232 ${libdir}/rpm/bin/wget \
233 ${localstatedir}/cache \
234 ${localstatedir}/cache/rpm \
235 ${localstatedir}/cache/wdj \
236 ${localstatedir}/lib \
237 ${localstatedir}/lib/rpm \
238 ${localstatedir}/lib/wdj \
239 ${bindir}/rpm.real \
240 ${bindir}/rpmconstant.real \
241 ${bindir}/rpm2cpio.real \
242 "
243
244FILES_${PN}-dbg += "${libdir}/rpm/.debug \
245 ${libdir}/rpm/bin/.debug \
246 "
247
248FILES_${PN}-common = "${bindir}/rpm2cpio \
249 ${bindir}/gendiff \
250 ${sysconfdir}/rpm \
251 ${localstatedir}/spool/repackage \
252 "
253
254FILES_${PN}-libs = "${libdir}/librpm-*.so \
255 ${libdir}/librpmconstant-*.so \
256 ${libdir}/librpmdb-*.so \
257 ${libdir}/librpmio-*.so \
258 ${libdir}/librpmmisc-*.so \
259 ${libdir}/librpmbuild-*.so \
260 "
261
262RDEPENDS_${PN}-build += "bash"
263
264FILES_${PN}-build = "${prefix}/src/rpm \
265 ${bindir}/rpmbuild \
266 ${bindir}/rpmbuild.real \
267 ${libdir}/rpm/brp-* \
268 ${libdir}/rpm/check-files \
269 ${libdir}/rpm/cross-build \
270 ${libdir}/rpm/find-debuginfo.sh \
271 ${libdir}/rpm/find-lang.sh \
272 ${libdir}/rpm/find-prov.pl \
273 ${libdir}/rpm/find-provides.perl \
274 ${libdir}/rpm/find-req.pl \
275 ${libdir}/rpm/find-requires.perl \
276 ${libdir}/rpm/getpo.sh \
277 ${libdir}/rpm/http.req \
278 ${libdir}/rpm/javadeps.sh \
279 ${libdir}/rpm/mono-find-provides \
280 ${libdir}/rpm/mono-find-requires \
281 ${libdir}/rpm/executabledeps.sh \
282 ${libdir}/rpm/libtooldeps.sh \
283 ${libdir}/rpm/osgideps.pl \
284 ${libdir}/rpm/perldeps.pl \
285 ${libdir}/rpm/perl.prov \
286 ${libdir}/rpm/perl.req \
287 ${libdir}/rpm/php.prov \
288 ${libdir}/rpm/php.req \
289 ${libdir}/rpm/pkgconfigdeps.sh \
290 ${libdir}/rpm/pythondeps.sh \
291 ${libdir}/rpm/bin/debugedit \
292 ${libdir}/rpm/bin/debugedit.real \
293 ${libdir}/rpm/bin/rpmcache \
294 ${libdir}/rpm/bin/rpmcache.real \
295 ${libdir}/rpm/bin/rpmcmp \
296 ${libdir}/rpm/bin/rpmcmp.real \
297 ${libdir}/rpm/bin/rpmdeps \
298 ${libdir}/rpm/bin/rpmdeps.real \
299 ${libdir}/rpm/bin/rpmdeps-oecore \
300 ${libdir}/rpm/bin/rpmdeps-oecore.real \
301 ${libdir}/rpm/bin/rpmdigest \
302 ${libdir}/rpm/bin/rpmdigest.real \
303 ${libdir}/rpm/bin/abi-compliance-checker.pl \
304 ${libdir}/rpm/bin/api-sanity-autotest.pl \
305 ${libdir}/rpm/bin/chroot \
306 ${libdir}/rpm/bin/cp \
307 ${libdir}/rpm/bin/dbsql \
308 ${libdir}/rpm/bin/find \
309 ${libdir}/rpm/bin/install-sh \
310 ${libdir}/rpm/bin/lua \
311 ${libdir}/rpm/bin/luac \
312 ${libdir}/rpm/bin/mkinstalldirs \
313 ${libdir}/rpm/bin/rpmlua \
314 ${libdir}/rpm/bin/rpmluac \
315 ${libdir}/rpm/bin/sqlite3 \
316 ${libdir}/rpm/macros.d/cmake \
317 ${libdir}/rpm/macros.d/java \
318 ${libdir}/rpm/macros.d/libtool \
319 ${libdir}/rpm/macros.d/mandriva \
320 ${libdir}/rpm/macros.d/mono \
321 ${libdir}/rpm/macros.d/perl \
322 ${libdir}/rpm/macros.d/php \
323 ${libdir}/rpm/macros.d/pkgconfig \
324 ${libdir}/rpm/macros.d/python \
325 ${libdir}/rpm/macros.d/ruby \
326 ${libdir}/rpm/macros.d/selinux \
327 ${libdir}/rpm/macros.d/tcl \
328 ${libdir}/rpm/macros.rpmbuild \
329 ${libdir}/rpm/u_pkg.sh \
330 ${libdir}/rpm/vpkg-provides.sh \
331 ${libdir}/rpm/vpkg-provides2.sh \
332 ${libdir}/rpm/perfile_rpmdeps.sh \
333 "
334RDEPENDS_${PN} = "base-files run-postinsts"
335RDEPENDS_${PN}_class-native = ""
336RDEPENDS_${PN}_class-nativesdk = ""
337RDEPENDS_${PN}-build = "file"
338
339RDEPENDS_python-rpm = "${PN}"
340
341FILES_python-rpm-dbg = "${libdir}/python*/site-packages/rpm/.debug/_*"
342FILES_python-rpm-dev = "${libdir}/python*/site-packages/rpm/*.la"
343FILES_python-rpm-staticdev = "${libdir}/python*/site-packages/rpm/*.a"
344FILES_python-rpm = "${libdir}/python*/site-packages/rpm"
345
346FILES_perl-module-rpm = "${libdir}/perl/*/* \
347 "
348
349FILES_perl-module-rpm-dev = "${prefix}/share/man/man3/RPM* \
350 "
351
352RDEPENDS_${PN}-dev += "bash"
353
354FILES_${PN}-dev = "${includedir}/rpm \
355 ${libdir}/librpm.la \
356 ${libdir}/librpm.so \
357 ${libdir}/librpmconstant.la \
358 ${libdir}/librpmconstant.so \
359 ${libdir}/librpmdb.la \
360 ${libdir}/librpmdb.so \
361 ${libdir}/librpmio.la \
362 ${libdir}/librpmio.so \
363 ${libdir}/librpmmisc.la \
364 ${libdir}/librpmmisc.so \
365 ${libdir}/librpmbuild.la \
366 ${libdir}/librpmbuild.so \
367 ${libdir}/rpm/lib/liblua.la \
368 ${libdir}/pkgconfig/rpm.pc \
369 ${libdir}/rpm/rpmdb_loadcvt \
370 "
371
372FILES_${PN}-staticdev = " \
373 ${libdir}/librpm.a \
374 ${libdir}/librpmconstant.a \
375 ${libdir}/librpmdb.a \
376 ${libdir}/librpmio.a \
377 ${libdir}/librpmmisc.a \
378 ${libdir}/librpmbuild.a \
379 ${libdir}/rpm/lib/liblua.a \
380 "
381
382do_configure() {
383 # Disable tests!
384 echo "all:" > ${S}/tests/Makefile.am
385 sed -e 's/@__MKDIR_P@/%{__mkdir} -p/' -i ${S}/macros/macros.in
386
387 ( cd ${S}; ${S}/autogen.sh )
388
389 # NASTY hack to make sure configure files the right pkg-config file...
390 sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \
391 -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i ${S}/configure
392
393 ( cd ${S}/syck ; set +e ; rm -- -l* ; make distclean ) || :
394
395 export varprefix=${localstatedir}
396 oe_runconf
397}
398
399do_install_append() {
400 sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
401 sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
402 sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
403 sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
404 sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros
405 sed -i -e 's,^#%_openall_before_chroot.*,%_openall_before_chroot\t1,' ${D}/${libdir}/rpm/macros
406
407 # Enable Debian style arbitrary tags...
408 sed -i -e 's,%_arbitrary_tags[^_].*,%_arbitrary_tags %{_arbitrary_tags_debian},' ${D}/${libdir}/rpm/macros
409
410 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
411 install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh
412
413 # Remove unpackaged files (based on list in rpm.spec)
414 rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm}
415
416 rm -f ${D}/${mandir}/man8/rpmcache.8*
417 rm -f ${D}/${mandir}/man8/rpmgraph.8*
418 rm -f ${D}/${mandir}/*/man8/rpmcache.8*
419 rm -f ${D}/${mandir}/*/man8/rpmgraph.8*
420 rm -rf ${D}/${mandir}/{fr,ko}
421
422 rm -f ${D}/${includedir}/popt.h
423 rm -f ${D}/${libdir}/libpopt.*
424 rm -f ${D}/${libdir}/pkgconfig/popt.pc
425 rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo
426 rm -f ${D}/${mandir}/man3/popt.3
427
428 rm -f ${D}/${mandir}/man1/xar.1*
429 rm -f ${D}/${bindir}/xar
430 rm -rf ${D}/${includedir}/xar
431 rm -f ${D}/${libdir}/libxar*
432
433 rm -f ${D}/${bindir}/lz*
434 rm -f ${D}/${bindir}/unlzma
435 rm -f ${D}/${bindir}/unxz
436 rm -f ${D}/${bindir}/xz*
437 rm -rf ${D}/${includedir}/lzma*
438 rm -f ${D}/${mandir}/man1/lz*.1
439 rm -f ${D}/${libdir}/pkgconfig/liblzma*
440
441 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
442 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
443
444 #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
445 # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
446 #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
447
448 # We don't want the default macro set
449 rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*}
450
451 rm -f ${D}/${libdir}/rpm/dbconvert.sh
452
453 rm -f ${D}/${libdir}/rpm/libsqldb.*
454
455 # We don't want, nor need the Mandriva multiarch items
456 rm -f ${D}/${bindir}/multiarch-dispatch
457 rm -f ${D}/${bindir}/multiarch-platform
458 rm -f ${D}/${libdir}/rpm/check-multiarch-files
459 rm -f ${D}/${libdir}/rpm/mkmultiarch
460 rm -f ${D}/${includedir}/multiarch-dispatch.h
461
462 rm -f ${D}/${libdir}/rpm/gstreamer.sh
463 rm -f ${D}/${libdir}/rpm/gem_helper.rb
464 rm -f ${D}/${libdir}/rpm/rubygems.rb
465 rm -f ${D}/${libdir}/rpm/kmod-deps.sh
466 rm -f ${D}/${libdir}/rpm/pythoneggs.py
467 rm -f ${D}/${libdir}/rpm/macros.d/kernel
468 rm -f ${D}/${libdir}/rpm/macros.d/gstreamer
469 rm -f ${D}/${libdir}/rpm/bin/mgo
470 rm -f ${D}/${libdir}/rpm/bin/dbconvert
471 rm -f ${D}/${libdir}/rpm/bin/pom2spec
472
473 rm -rf ${D}/var/lib/wdj ${D}/var/cache/wdj
474 rm -f ${D}/${libdir}/rpm/bin/api-sanity-checker.pl
475
476}
477
478add_native_wrapper() {
479 create_wrapper ${D}/${bindir}/rpm \
480 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
481 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
482 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
483
484 create_wrapper ${D}/${bindir}/rpm2cpio \
485 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
486 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
487 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
488
489 create_wrapper ${D}/${bindir}/rpmbuild \
490 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
491 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
492 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
493
494 create_wrapper ${D}/${bindir}/rpmconstant \
495 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
496 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
497 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
498
499 for rpm_binary in ${D}/${libdir}/rpm/bin/rpm* ${D}/${libdir}/rpm/bin/debugedit; do
500 create_wrapper $rpm_binary \
501 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
502 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
503 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
504 done
505}
506
507do_install_append_class-native() {
508 add_native_wrapper
509}
510
511do_install_append_class-nativesdk() {
512 add_native_wrapper
513}
514
515BBCLASSEXTEND = "native nativesdk"