summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.14.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-12-02 03:39:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-12 23:42:53 +0000
commitbc26a7d34cf1705e1a2acac561259ee1610d7da2 (patch)
treec06662a64155839288b03d6c2d787e78d0361426 /meta/recipes-devtools/rpm/rpm_5.4.14.bb
parent01c0285677b4b831bcb9c796337f7e888f1d76ec (diff)
downloadpoky-bc26a7d34cf1705e1a2acac561259ee1610d7da2.tar.gz
rpm: fix file conflicts for MIPS64 N32
The following error can occur: smart install libc6-2.22-r0.1@lib32_mips32r2octeon3 libc6-dbg-2.22-r0.1@lib32_mips32r2octeon3 error: file /sbin/ldconfig conflicts between attempted installs of libc6-2.22-r0.1.lib32_mips32r2octeon3 and libc6-2.22-r0.1.octeon3_n32 error: file /sbin/.debug/ldconfig conflicts between attempted installs of libc6-dbg-2.22-r0.1.lib32_mips32r2octeon3 and libc6-dbg-2.22-r0.1.octeon3_n32 This was because: transactions_color = 001 (ELF32) & 010 (ELF64) & 100 (ELF32 N32 MIPS64) FColor = Current file color (001) & transaction_color (111) oFcolor = Previous file color (100) & transaction_color (111) There are two places where the conflict comparisons occur. In both places the 'else' clause was too restrictive (opposite of the 'positive' clause). This caused the system to only permit a binary comparison - "new preferred" or "old preferred". It did not permissing "neither preferred". By removing the else comparison the system will now perform a 'last-in-wins' resolution when "neither is preferred". Note, if _transaction_color is 3, MIPS64 N32 will be skipped (pretend as installed). (From OE-Core rev: 36c225704daa58b98a4b7f2ef315eb944d8628b5) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.14.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.14.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.14.bb b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
index 58a0934f0d..97651d28af 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.14.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
@@ -102,6 +102,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.14-0.20131024.src.rpm;e
102 file://configure.ac-check-for-both-gpg2-and-gpg.patch \ 102 file://configure.ac-check-for-both-gpg2-and-gpg.patch \
103 file://0001-define-EM_AARCH64.patch \ 103 file://0001-define-EM_AARCH64.patch \
104 file://rpm-rpmfc.c-fix-for-N32-MIPS64.patch \ 104 file://rpm-rpmfc.c-fix-for-N32-MIPS64.patch \
105 file://rpm-lib-transaction.c-fix-file-conflicts-for-mips64-N32.patch \
105 " 106 "
106 107
107# Uncomment the following line to enable platform score debugging 108# Uncomment the following line to enable platform score debugging