diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2011-02-01 12:26:31 -0600 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-02-01 23:59:42 +0000 |
commit | d71f6fff17e7a2bd5acd4339b26a2d3b28c76814 (patch) | |
tree | 4fa3760641ca897cce16f42c7604fd1a263b8bb4 /meta/recipes-devtools/rpm/rpm_5.4.0.bb | |
parent | c22484279df745f37b3e80b125059d4167b01b7b (diff) | |
download | poky-d71f6fff17e7a2bd5acd4339b26a2d3b28c76814.tar.gz |
rpm: Add relocation to rpm-native
[BUGID #668]
Use the create_wrapper to setup automatic run-time relocation of
rpm-native.
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.0.bb')
-rw-r--r-- | meta/recipes-devtools/rpm/rpm_5.4.0.bb | 28 |
1 files changed, 27 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.0.bb b/meta/recipes-devtools/rpm/rpm_5.4.0.bb index 0f3425f794..09d1fc0a62 100644 --- a/meta/recipes-devtools/rpm/rpm_5.4.0.bb +++ b/meta/recipes-devtools/rpm/rpm_5.4.0.bb | |||
@@ -43,7 +43,7 @@ LICENSE = "LGPL 2.1" | |||
43 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1" | 43 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1" |
44 | 44 | ||
45 | DEPENDS = "bzip2 zlib python perl db openssl elfutils expat libpcre attr acl popt" | 45 | DEPENDS = "bzip2 zlib python perl db openssl elfutils expat libpcre attr acl popt" |
46 | PR = "r9" | 46 | PR = "r10" |
47 | 47 | ||
48 | # rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed | 48 | # rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed |
49 | # in order to extract the distribution SRPM into a format we can extract... | 49 | # in order to extract the distribution SRPM into a format we can extract... |
@@ -430,4 +430,30 @@ do_install_append() { | |||
430 | rm -f ${D}/${libdir}/rpm/libsqldb.* | 430 | rm -f ${D}/${libdir}/rpm/libsqldb.* |
431 | } | 431 | } |
432 | 432 | ||
433 | do_install_append_virtclass-native() { | ||
434 | create_wrapper ${D}/${bindir}/rpm \ | ||
435 | RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
436 | RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \ | ||
437 | RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale | ||
438 | |||
439 | create_wrapper ${D}/${bindir}/rpm2cpio \ | ||
440 | RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
441 | RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \ | ||
442 | RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale | ||
443 | |||
444 | create_wrapper ${D}/${bindir}/rpmbuild \ | ||
445 | RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
446 | RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \ | ||
447 | RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale | ||
448 | |||
449 | create_wrapper ${D}/${bindir}/rpmconstant \ | ||
450 | RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
451 | RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \ | ||
452 | RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale | ||
453 | |||
454 | # Adjust popt macros to match... | ||
455 | cat ${D}/${libdir}/rpm/rpmpopt | sed -e "s,^\(rpm[^ ]*\)\([ ]\),\1.real\2," > ${D}/${libdir}/rpm/rpmpopt.new | ||
456 | mv ${D}/${libdir}/rpm/rpmpopt.new ${D}/${libdir}/rpm/rpmpopt | ||
457 | } | ||
458 | |||
433 | BBCLASSEXTEND = "native" | 459 | BBCLASSEXTEND = "native" |