summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.1.10.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-01-15 21:36:23 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-28 17:52:55 +0000
commitf6ddba2a9dc15560f639faaba8233c29c0c37e9d (patch)
tree568c80749bdfd9c005c769bbb49b18a6b1390cff /meta/recipes-devtools/rpm/rpm_5.1.10.bb
parenta606ad5022e7c0ca34a5bc086254ac8ec16bc8c7 (diff)
downloadpoky-f6ddba2a9dc15560f639faaba8233c29c0c37e9d.tar.gz
rpm: Uprev to RPM 5.4.0
Update RPM to the latest release, RPM 5.4.0. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.1.10.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.1.10.bb168
1 files changed, 0 insertions, 168 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.1.10.bb b/meta/recipes-devtools/rpm/rpm_5.1.10.bb
deleted file mode 100644
index b9ba8dbb4c..0000000000
--- a/meta/recipes-devtools/rpm/rpm_5.1.10.bb
+++ /dev/null
@@ -1,168 +0,0 @@
1DESCRIPTION = "The RPM Package Manager - relaunched"
2DESCRIPTION_rpm-build = "The RPM Package Manager rpmbuild and related commands."
3HOMEPAGE = "http://rpm5.org/"
4LICENSE = "LGPL 2.1"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
6
7DEPENDS = "zlib perl popt beecrypt python libpcre elfutils"
8PR = "r8"
9
10SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.1/POKY/${BPN}-${PV}.tar.gz \
11 file://hdraddorappend.patch \
12 file://export-rpmbag-h.patch \
13 file://rpm-nrescan.patch \
14 file://rpm-autoconf.patch \
15 file://remove-compiled-tests.patch;apply=no \
16 file://perfile_rpmdeps.sh \
17 file://rpm-no-loop.patch \
18 "
19
20SRC_URI[md5sum] = "a5deb83b451f11c04461c630937b1189"
21SRC_URI[sha256sum] = "701726a6ae8283fcabc308dae523ad9599388296a562db1b3d7d7c871641af7e"
22inherit autotools gettext
23
24acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
25
26# Specify the default rpm macros in terms of adjustable variables
27rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
28
29EXTRA_OECONF = "--with-python=${PYTHON_BASEVERSION} \
30 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
31 --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION} \
32 --with-db=internal \
33 --with-db-tools-integrated \
34 --with-libelf \
35 --with-file=internal \
36 --without-apidocs \
37 --without-selinux \
38 --without-lua \
39 --without-dmalloc \
40 --without-efence \
41 --without-neon \
42 --with-pcre=internal \
43 --with-path-macros=${rpm_macros} \
44 --with-bugreport=http://bugzilla.pokylinux.org"
45
46CFLAGS_append = " -DRPM_VENDOR_WINDRIVER"
47
48PACKAGES =+ "rpm-build python-rpm python-rpm-dbg"
49
50SOLIBS = "5.0.so"
51
52FILES_rpm-build = "${bindir}/*-rpmbuild \
53 ${bindir}/*-gendiff \
54 ${bindir}/*-rpmspecdump \
55 ${libdir}/rpm/helpers/* \
56 ${libdir}/rpm/*brp* \
57 ${libdir}/rpm/*check-files \
58 ${libdir}/rpm/*cross-build \
59 ${libdir}/rpm/*debugedit \
60 ${libdir}/rpm/*dep* \
61 ${libdir}/rpm/*prov* \
62 ${libdir}/rpm/*req* \
63 ${libdir}/rpm/*find* \
64 ${libdir}/rpm/qf/* \
65 "
66
67FILES_python-rpm = "${libdir}/python*/rpm/_*"
68FILES_python-rpm-dbg = "${libdir}/python*/rpm/.debug/_*"
69
70# The mutex needs to be POSIX/pthreads/library or we can't
71# share a database between host and target environments
72# (there is a minor performance penalty, but not one great enough
73# to justify the pain of a more optimized approach!)
74EXTRA_OECONF += "--with-mutex=POSIX/pthreads/library"
75
76do_configure() {
77 # Manually run through the steps of the autogen.sh
78 ( cd pcre
79 libtoolize --quiet --copy --force --install
80 aclocal
81 autoheader
82 automake -Wall -Wno-override -a -c
83 autoconf
84 )
85
86 ( cd xz
87 autopoint -f
88 rm -f \
89 codeset.m4 \
90 glibc2.m4 \
91 glibc21.m4 \
92 intdiv0.m4 \
93 intl.m4 \
94 intldir.m4 \
95 intmax.m4 \
96 inttypes-pri.m4 \
97 inttypes_h.m4 \
98 lcmessage.m4 \
99 lock.m4 \
100 longdouble.m4 \
101 longlong.m4 \
102 printf-posix.m4 \
103 size_max.m4 \
104 stdint_h.m4 \
105 uintmax_t.m4 \
106 ulonglong.m4 \
107 visibility.m4 \
108 wchar_t.m4 \
109 wint_t.m4 \
110 xsize.m4
111 libtoolize -c -f || glibtoolize -c -f
112 aclocal -I m4
113 autoconf
114 autoheader
115 automake -acf --foreign
116 )
117
118 ( cd file
119 libtoolize --quiet --copy --force --install
120 aclocal
121 autoheader
122 automake -Wall -Wno-override -a -c
123 autoconf
124 )
125
126 (cd syck
127 libtoolize --quiet --copy --force --install
128 aclocal
129 autoheader
130 automake -Wall -Wno-override -a -c
131 autoconf
132 )
133
134 (cd xar
135 libtoolize --quiet --copy --force --install
136 aclocal
137 autoheader
138 automake -Wall -Wno-override -a -c
139 autoconf
140 )
141
142 rm -rf autom4te.cache || true
143 libtoolize --quiet --copy --force --install
144 autopoint --force
145 rm -f aclocal.m4
146 aclocal -I m4
147 autoheader -I m4
148 automake -Wall -Wno-override -a -c
149 autoconf -I m4
150 # end of autogen.sh steps
151
152 export ac_cv_va_copy=C99
153 oe_runconf
154}
155
156do_install_append() {
157 sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
158 sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
159 sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros
160 sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros
161
162 # Enable Debian style arbitrary tags...
163 sed -i -e 's,%_arbitrary_tags[^_].*,%_arbitrary_tags %{_arbitrary_tags_debian},' ${D}/${libdir}/rpm/macros
164
165 install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh
166}
167
168BBCLASSEXTEND = "native"