summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_4.11.2.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-09-30 10:16:54 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-30 21:36:13 +0100
commit58d9c4e4babbefecc187be2d7f1b812b76d6efc9 (patch)
tree4f6ee75962b5c79fa754730f3e6847751fabc42a /meta/recipes-devtools/rpm/rpm_4.11.2.bb
parent6be3386e78ec8aac1fd1631047ddf967f4843f3d (diff)
downloadpoky-58d9c4e4babbefecc187be2d7f1b812b76d6efc9.tar.gz
rpm: add version 4.11.2
add patch to remove db3 from configure.ac add inherit pkgconfig (From OE-Core rev: 9a17f938e738a16a1ef9a00be6a8317d71f92573) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_4.11.2.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.11.2.bb133
1 files changed, 133 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.11.2.bb b/meta/recipes-devtools/rpm/rpm_4.11.2.bb
new file mode 100644
index 0000000000..86a14fae50
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm_4.11.2.bb
@@ -0,0 +1,133 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22LICENSE = "GPL-2.0+"
23LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
24
25DEPENDS = "db libxml2 xz findutils file popt nss bzip2 elfutils patch attr zlib acl gzip make binutils python"
26
27SRC_URI += "http://rpm.org/releases/rpm-4.11.x/${BP}.tar.bz2 \
28 file://use-pkgconfig-for-python.patch \
29 file://remove-db3-from-configure.patch \
30 file://add_RPMSENSE_MISSINGOK_to_rpmmodule.patch \
31 file://support-suggests-tag.patch \
32 file://remove-dir-check.patch \
33 file://disable_shortcircuited.patch \
34 file://fix_libdir.patch \
35 file://rpm-scriptetexechelp.patch \
36 file://pythondeps.sh \
37 "
38
39SRC_URI[md5sum] = "876ac9948a88367054f8ddb5c0e87173"
40SRC_URI[sha256sum] = "403f8de632b33846ce5746f429c21a60f40dff9dcb56f1b4118f37a0652a48d4"
41
42inherit autotools-brokensep
43inherit pythonnative
44inherit pkgconfig
45inherit gettext
46
47EXTRA_OECONF += "--host=${HOST_SYS} \
48 --program-prefix= \
49 --prefix=${prefix} \
50 --exec-prefix=${prefix} \
51 --bindir=${prefix}/bin \
52 --sbindir=${prefix}/sbin \
53 --sysconfdir=${sysconfdir} \
54 --datadir=${prefix}/share \
55 --includedir=${prefix}/include \
56 --libdir=${prefix}/lib \
57 --libexecdir=${prefix}/libexec \
58 --localstatedir=${localstatedir} \
59 --sharedstatedir=${prefix}/com \
60 --mandir=${mandir} \
61 --infodir=${infodir} \
62 --disable-dependency-tracking \
63 --with-acl \
64 --without-lua \
65 --without-cap \
66 --enable-shared \
67 --enable-python \
68 --with-external-db \
69 "
70
71CPPFLAGS_append = " `pkg-config --cflags nss`"
72LDFLAGS_append = " -Wl,-Bsymbolic-functions -ffunction-sections"
73CCFLAGS_append = " -fPIC "
74CXXFLAGS_append = " -fPIC "
75CFLAGS_append = " -fPIC -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY -DRPM_VENDOR_OE "
76
77do_configure_prepend() {
78 rm -rf sqlite
79 rm -f m4/libtool.m4
80 rm -f m4/lt*.m4
81 rm -rf db3/configure*
82}
83
84do_install_append() {
85 mv ${D}/${base_bindir}/rpm ${D}/${bindir}/
86 rmdir ${D}/${base_bindir}
87 rm -f ${D}${prefix}/lib/*.la
88 rm -f ${D}${prefix}/lib/rpm-plugins/*.la
89 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
90 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
91 rm -fr ${D}/var
92 install -d ${D}${prefix}/lib/rpm/bin
93 ln -s ../debugedit ${D}${prefix}/lib/rpm/bin/debugedit
94 ln -s ../rpmdeps ${D}${prefix}/lib/rpm/bin/rpmdeps-oecore
95 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
96}
97
98pkg_postinst_${PN}() {
99
100 [ "x\$D" == "x" ] && ldconfig
101 test -f ${localstatedir}/lib/rpm/Packages || rpm --initdb
102 rm -f ${localstatedir}/lib/rpm/Filemd5s \
103 ${localstatedir}/lib/rpm/Filedigests \
104 ${localstatedir}/lib/rpm/Requireversion \
105 ${localstatedir}/lib/rpm/Provideversion
106
107}
108
109pkg_postrm_${PN}() {
110 [ "x\$D" == "x" ] && ldconfig
111
112}
113
114PACKAGES += "python-${PN}"
115PROVIDES += "python-rpm"
116
117FILES_${PN} += "${libdir}/rpm \
118 ${libdir}/rpm-plugins/exec.so \
119 "
120RDEPENDS_${PN} = "base-files run-postinsts"
121RDEPENDS_${PN}_class-native = "base-files run-postinsts"
122
123FILES_${PN}-dbg += "${libdir}/rpm/.debug/* \
124 ${libdir}/rpm-plugins/.debug/* \
125 ${libdir}/python2.7/site-packages/rpm/.debug/* \
126 "
127
128FILES_${PN}-dev += "${libdir}/python2.7/site-packages/rpm/*.la"
129
130FILES_python-${PN} = "${libdir}/python2.7/site-packages/rpm/*"
131RDEPENDS_python-${PN} = "${PN} python"
132
133BBCLASSEXTEND = "native"