summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_4.11.2.bb
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-03-11 14:07:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-20 23:12:29 +0000
commit1e9de52ca0d3765ca47ec18fc9e71172257ff3c1 (patch)
treef75492bbcbdf527fd87155ea9bfafa969b895fd0 /meta/recipes-devtools/rpm/rpm_4.11.2.bb
parenta7dd04d15b0208c5d159abb7b40079c62aa60d78 (diff)
downloadpoky-1e9de52ca0d3765ca47ec18fc9e71172257ff3c1.tar.gz
rpm: remove RPM 4
RPM4 support is buggy and incomplete. As we don't have the resources or interest to maintain it this patch removes it. (From OE-Core rev: a6e7a86f1635be9a688c56c25e9d215ea4d2cc84) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_4.11.2.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.11.2.bb132
1 files changed, 0 insertions, 132 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.11.2.bb b/meta/recipes-devtools/rpm/rpm_4.11.2.bb
deleted file mode 100644
index 3683971cd5..0000000000
--- a/meta/recipes-devtools/rpm/rpm_4.11.2.bb
+++ /dev/null
@@ -1,132 +0,0 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22LICENSE = "GPL-2.0+"
23LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
24
25DEPENDS = "db libxml2 xz findutils file popt nss bzip2 elfutils attr zlib acl gzip python"
26DEPENDS_append_class-native = " file-replacement-native"
27
28SRC_URI += "http://rpm.org/releases/rpm-4.11.x/${BP}.tar.bz2 \
29 file://use-pkgconfig-for-python.patch \
30 file://remove-db3-from-configure.patch \
31 file://add_RPMSENSE_MISSINGOK_to_rpmmodule.patch \
32 file://support-suggests-tag.patch \
33 file://remove-dir-check.patch \
34 file://disable_shortcircuited.patch \
35 file://fix_libdir.patch \
36 file://rpm-scriptetexechelp.patch \
37 file://pythondeps.sh \
38 file://rpm-CVE-2014-8118.patch \
39 file://rpm-CVE-2013-6435.patch \
40 "
41
42SRC_URI[md5sum] = "876ac9948a88367054f8ddb5c0e87173"
43SRC_URI[sha256sum] = "403f8de632b33846ce5746f429c21a60f40dff9dcb56f1b4118f37a0652a48d4"
44
45PR = "r1"
46
47inherit autotools
48inherit pythonnative
49inherit pkgconfig
50inherit gettext
51
52EXTRA_OECONF += "--host=${HOST_SYS} \
53 --program-prefix= \
54 --prefix=${prefix} \
55 --exec-prefix=${prefix} \
56 --bindir=${prefix}/bin \
57 --sbindir=${prefix}/sbin \
58 --sysconfdir=${sysconfdir} \
59 --datadir=${prefix}/share \
60 --includedir=${prefix}/include \
61 --libdir=${prefix}/lib \
62 --libexecdir=${prefix}/libexec \
63 --localstatedir=${localstatedir} \
64 --sharedstatedir=${prefix}/com \
65 --mandir=${mandir} \
66 --infodir=${infodir} \
67 --disable-dependency-tracking \
68 --with-acl \
69 --without-lua \
70 --without-cap \
71 --enable-shared \
72 --enable-python \
73 --with-external-db \
74 "
75
76CPPFLAGS_append = " `pkg-config --cflags nss`"
77LDFLAGS_append = " -Wl,-Bsymbolic-functions -ffunction-sections"
78CCFLAGS_append = " -fPIC "
79CXXFLAGS_append = " -fPIC "
80CFLAGS_append = " -fPIC -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY -DRPM_VENDOR_OE "
81
82do_configure_prepend() {
83 rm -rf sqlite
84 rm -f m4/libtool.m4
85 rm -f m4/lt*.m4
86 rm -rf db3/configure*
87}
88
89do_install_append() {
90 mv ${D}/${base_bindir}/rpm ${D}/${bindir}/
91 rmdir ${D}/${base_bindir}
92 rm -f ${D}${prefix}/lib/*.la
93 rm -f ${D}${prefix}/lib/rpm-plugins/*.la
94 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
95 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
96 rm -fr ${D}/var
97 install -d ${D}${prefix}/lib/rpm/bin
98 ln -s ../debugedit ${D}${prefix}/lib/rpm/bin/debugedit
99 ln -s ../rpmdeps ${D}${prefix}/lib/rpm/bin/rpmdeps-oecore
100 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
101}
102
103pkg_postinst_${PN}() {
104 [ "x\$D" = "x" ] && ldconfig
105 test -f ${localstatedir}/lib/rpm/Packages || rpm --initdb
106 rm -f ${localstatedir}/lib/rpm/Filemd5s \
107 ${localstatedir}/lib/rpm/Filedigests \
108 ${localstatedir}/lib/rpm/Requireversion \
109 ${localstatedir}/lib/rpm/Provideversion
110
111}
112
113pkg_postrm_${PN}() {
114 [ "x\$D" = "x" ] && ldconfig
115
116}
117
118PACKAGES += "python-${PN}"
119PROVIDES += "python-rpm"
120
121FILES_${PN} += "${libdir}/rpm \
122 ${libdir}/rpm-plugins/exec.so \
123 "
124RDEPENDS_${PN} = "base-files run-postinsts"
125RDEPENDS_${PN}_class-native = ""
126
127FILES_${PN}-dev += "${libdir}/python2.7/site-packages/rpm/*.la"
128
129FILES_python-${PN} = "${libdir}/python2.7/site-packages/rpm/*"
130RDEPENDS_python-${PN} = "${PN} python"
131
132BBCLASSEXTEND = "native"