diff options
author | Chen Qi <Qi.Chen@windriver.com> | 2013-07-19 17:39:25 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-07-29 13:09:11 +0100 |
commit | 7e348654988b1701f58646ab32a18f4d389f7058 (patch) | |
tree | 774faf9db568bd48e4a67bde4648781c59dc9eaa /meta/recipes-devtools/rpm/rpm-postinsts.bb | |
parent | ab2a6a8c4cf9dc706c41819818791838205939f2 (diff) | |
download | poky-7e348654988b1701f58646ab32a18f4d389f7058.tar.gz |
rpm: remove the obsolete rpm-postinsts.bb
Now that the postinsts of rpm, deb and ipk are all handled in the one
central place, run-postinsts.bb, the rpm-postinsts.bb recipe is actually
obsolete now. Remove this recipe to avoid confusion.
(From OE-Core rev: 308185c215b8dd969d1230e52444ce3c11fc2c57)
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm-postinsts.bb')
-rw-r--r-- | meta/recipes-devtools/rpm/rpm-postinsts.bb | 54 |
1 files changed, 0 insertions, 54 deletions
diff --git a/meta/recipes-devtools/rpm/rpm-postinsts.bb b/meta/recipes-devtools/rpm/rpm-postinsts.bb deleted file mode 100644 index ba58cd49b1..0000000000 --- a/meta/recipes-devtools/rpm/rpm-postinsts.bb +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | DESCRIPTION = "RPM postinstall script" | ||
2 | SECTION = "core" | ||
3 | LICENSE = "LGPLv2.1" | ||
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780" | ||
5 | |||
6 | inherit allarch | ||
7 | # | ||
8 | # Allow distributions to alter when [postponed] package install scripts are run | ||
9 | # | ||
10 | POSTINSTALL_INITPOSITION ?= "98" | ||
11 | |||
12 | do_fetch() { | ||
13 | : | ||
14 | } | ||
15 | |||
16 | do_configure() { | ||
17 | : | ||
18 | } | ||
19 | |||
20 | do_compile() { | ||
21 | : | ||
22 | } | ||
23 | |||
24 | do_install() { | ||
25 | : | ||
26 | } | ||
27 | |||
28 | pkg_postinst_${PN} () { | ||
29 | if [ "x$D" != "x" ] && [ -f $D/var/lib/rpm/Packages ]; then | ||
30 | install -d $D/${sysconfdir}/rcS.d | ||
31 | cat > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts << "EOF" | ||
32 | #!/bin/sh | ||
33 | [ -e ${sysconfdir}/default/postinst ] && . ${sysconfdir}/default/postinst | ||
34 | [ -d ${sysconfdir}/rpm-postinsts ] && for i in `ls ${sysconfdir}/rpm-postinsts/`; do | ||
35 | i=${sysconfdir}/rpm-postinsts/$i | ||
36 | echo "Running postinst $i..." | ||
37 | if [ -x $i ]; then | ||
38 | if [ "$POSTINST_LOGGING" = "1" ]; then | ||
39 | $i >>$LOGFILE 2>&1 | ||
40 | else | ||
41 | $i | ||
42 | fi | ||
43 | rm $i | ||
44 | else | ||
45 | echo "ERROR: postinst $i failed." | ||
46 | fi | ||
47 | done | ||
48 | rm -f ${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts 2>/dev/null | ||
49 | EOF | ||
50 | chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts | ||
51 | fi | ||
52 | } | ||
53 | |||
54 | ALLOW_EMPTY_${PN} = "1" | ||