summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/repo/repo_2.42.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-03-06 07:42:23 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-07 17:25:03 +0000
commit494b7c73c8a38efdfa3d4894e8078bf69e371a38 (patch)
tree88e7985d7087da1c47d0a7a120279c03b681a7dc /meta/recipes-devtools/repo/repo_2.42.bb
parent8479b1d2f9c69e663b84c6ec93e962cae5fc350c (diff)
downloadpoky-494b7c73c8a38efdfa3d4894e8078bf69e371a38.tar.gz
repo: upgrade 2.41 -> 2.42
Drop patch as issue fixed upstream: https://gerrit.googlesource.com/git-repo/+/b8139bdcf87540fbe88a8b9180c052f5cc3a91b7 (From OE-Core rev: a6f2c8bf9306184e2184d7c5187e4db677cdcae2) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/repo/repo_2.42.bb')
-rw-r--r--meta/recipes-devtools/repo/repo_2.42.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/repo/repo_2.42.bb b/meta/recipes-devtools/repo/repo_2.42.bb
new file mode 100644
index 0000000000..9bb5000fab
--- /dev/null
+++ b/meta/recipes-devtools/repo/repo_2.42.bb
@@ -0,0 +1,30 @@
1# SPDX-License-Identifier: MIT
2# Copyright (C) 2021 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "Tool for managing many Git repositories"
5DESCRIPTION = "Repo is a tool built on top of Git. Repo helps manage many Git repositories, does the uploads to revision control systems, and automates parts of the development workflow."
6HOMEPAGE = "https://android.googlesource.com/tools/repo"
7SECTION = "console/utils"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRC_URI = "git://gerrit.googlesource.com/git-repo.git;protocol=https;branch=main \
13 "
14SRCREV = "5554572f02537b8646139d59ab520e59e1d5f7b3"
15
16MIRRORS += "git://gerrit.googlesource.com/git-repo.git git://github.com/GerritCodeReview/git-repo.git"
17
18S = "${WORKDIR}/git"
19
20do_configure:prepend() {
21 sed -Ei "s/REPO_REV\s*=\s*('|\")stable('|\")/REPO_REV = '${SRCREV}'/g" ${S}/repo
22}
23
24do_install() {
25 install -D ${WORKDIR}/git/repo ${D}${bindir}/repo
26}
27
28RDEPENDS:${PN} = "python3 git"
29
30BBCLASSEXTEND = "native nativesdk"