summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/remake/remake_git.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-devtools/remake/remake_git.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/remake/remake_git.bb')
-rw-r--r--meta/recipes-devtools/remake/remake_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/remake/remake_git.bb b/meta/recipes-devtools/remake/remake_git.bb
new file mode 100644
index 0000000000..2ba2b809f8
--- /dev/null
+++ b/meta/recipes-devtools/remake/remake_git.bb
@@ -0,0 +1,31 @@
1PR = "r1"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
5 file://glob/COPYING.LIB;md5=4a770b67e6be0f60da244beb2de0fce4"
6require remake.inc
7
8SRC_URI += "file://version-remake.texi.patch \
9 file://remake-remove-errors-about-colophon-and-cygnus-comma.patch \
10 "
11SRCREV = "f05508e521987c8494c92d9c2871aec46307d51d"
12S = "${WORKDIR}/git"
13
14PV = "3.82+dbg-0.9+git${SRCPV}"
15
16DEPENDS += "readline"
17# Need to add "gettext-native" dependency to remake-native.
18# By default only "gettext-minimal-native" is added
19# when inherit gettext.
20DEPENDS_class-native += "gettext-native"
21PROVIDES += "make"
22
23do_configure_prepend() {
24 # remove the default LINGUAS since we are not going to generate languages
25 rm ${S}/po/LINGUAS
26 touch ${S}/po/LINGUAS
27 # create config.rpath which required by configure.ac
28 ( cd ${S}; autopoint || touch config.rpath )
29}
30
31BBCLASSEXTEND = "native"