summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/quilt/quilt_0.65.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-03-30 19:49:28 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-05 23:22:13 +0100
commite908ffe3cddd767cc1df4803e5ac8aed9f369bb1 (patch)
treed3bbfe036e2ba49953f0112e29b07ba555954ca3 /meta/recipes-devtools/quilt/quilt_0.65.bb
parent9cacf8488ca2f7de346ce3085d312ee017e4e39f (diff)
downloadpoky-e908ffe3cddd767cc1df4803e5ac8aed9f369bb1.tar.gz
quilt: Fix paths for patch and perl
Currently some shebang lines end up as #! /usr/bin/env perl -w env does not like the argument. Also the current sed to insert env does not cover the copies ptests use. Fix these issues by: - using --with-perl to insert "env" - Replacing "-w" in shebang lines with a new "use warning;" line Remove a EXTRA_OECONF_append_class_target from the native recipe. Don't overwrite EXTRA_OECONF in native: the values should be correct for native as well. --with-patch is used within the gnu patch wrapper only: before this commit the wrapper contained a (build host) path to native patch. Also tweak one test so busybox mv output is accepted. All ptests should now pass: Fixes [YOCTO #11221]. (From OE-Core rev: 4b667d268fe410a21cacaecd1b5e3bfbbe7d53d8) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/quilt/quilt_0.65.bb')
-rw-r--r--meta/recipes-devtools/quilt/quilt_0.65.bb10
1 files changed, 0 insertions, 10 deletions
diff --git a/meta/recipes-devtools/quilt/quilt_0.65.bb b/meta/recipes-devtools/quilt/quilt_0.65.bb
index 00f900a112..12859f0bcc 100644
--- a/meta/recipes-devtools/quilt/quilt_0.65.bb
+++ b/meta/recipes-devtools/quilt/quilt_0.65.bb
@@ -4,13 +4,3 @@ RDEPENDS_${PN} += "patch diffstat bzip2 util-linux"
4SRC_URI += "file://aclocal.patch \ 4SRC_URI += "file://aclocal.patch \
5 file://gnu_patch_test_fix_target.patch \ 5 file://gnu_patch_test_fix_target.patch \
6 " 6 "
7
8# fix build-distro specific perl path in the target perl scripts
9do_install_append() {
10 for perlscript in ${D}${datadir}/quilt/scripts/remove-trailing-ws ${D}${datadir}/quilt/scripts/dependency-graph ${D}${datadir}/quilt/scripts/edmail ${D}${bindir}/guards
11 do
12 if [ -f $perlscript ]; then
13 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' $perlscript
14 fi
15 done
16}