summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_5.1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-13 14:44:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-17 08:45:35 +0100
commit7e25a6b4d52a16e812dfd444d65283d2c75d2d77 (patch)
tree1f61c98c9d24ed35b685af62bcdb1d83a36b80f9 /meta/recipes-devtools/qemu/qemu_5.1.0.bb
parent1bff01bda9741ad3a9b9e1937d73859636575c7c (diff)
downloadpoky-7e25a6b4d52a16e812dfd444d65283d2c75d2d77.tar.gz
qemu: Upgrade 5.0.0 -> 5.1.0
* Drop backported CVE fixes * Drop cpu backtrace patch from 2015 for debugging an issue which we no longer see (patch throws rejects, files have moved) * Update mips patch to account for file renames * Update chardev patch to match upstream code changes * Update webkitgtk patch, qemumips build works ok but qemux86 musl webkitgtk still fails. Need to figure out the correct fix and upstream it for this, current revert patch is not maintainable. Release notes for 5.1.0 mention slight qemumips performance improvements which would be valuable to us. My tests show no improvement in qemumips testimage execution time for core-image-sato-sdk. Fix a ptest issue for a file looking for /usr/bin/bash when we have /bin/bash. (From OE-Core rev: 686b770af67fdd2251f4ddab5b0eefc8fb0870ef) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_5.1.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_5.1.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_5.1.0.bb b/meta/recipes-devtools/qemu/qemu_5.1.0.bb
new file mode 100644
index 0000000000..9b09490269
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu_5.1.0.bb
@@ -0,0 +1,33 @@
1BBCLASSEXTEND = "nativesdk"
2
3require qemu.inc
4
5# error: a parameter list without types is only allowed in a function definition
6# void (*_function)(sigval_t);
7COMPATIBLE_HOST_libc-musl = 'null'
8
9DEPENDS = "glib-2.0 zlib pixman bison-native"
10
11RDEPENDS_${PN}_class-target += "bash"
12
13# Does not compile for -Og because that level does not clean up dead-code.
14# See lockable.h.
15#
16DEBUG_BUILD = "0"
17
18EXTRA_OECONF_append_class-target = " --target-list=${@get_qemu_target_list(d)}"
19EXTRA_OECONF_append_class-target_mipsarcho32 = "${@bb.utils.contains('BBEXTENDCURR', 'multilib', ' --disable-capstone', '', d)}"
20EXTRA_OECONF_append_class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"
21
22do_install_append_class-nativesdk() {
23 ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)}
24}
25
26PACKAGECONFIG ??= " \
27 fdt sdl kvm \
28 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '' ,d)} \
30"
31PACKAGECONFIG_class-nativesdk ??= "fdt sdl kvm \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '' ,d)} \
33"