summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_4.0.0.bb
diff options
context:
space:
mode:
authorAlistair Francis <Alistair.Francis@wdc.com>2019-05-02 04:09:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-03 06:11:57 +0100
commit69085ccb296b35b0b0ed67c871f0f60106c27a48 (patch)
tree22db1a527ff808d887da933a78c12408393c9280 /meta/recipes-devtools/qemu/qemu_4.0.0.bb
parent3d19803cbd0869dd55dbc778dacf6f6397374457 (diff)
downloadpoky-69085ccb296b35b0b0ed67c871f0f60106c27a48.tar.gz
qemu: Upgrade from 3.1.0 to 4.0.0
This commit upgrade QEMU to the latest 4.0.0 release. - The COPYING.LIB file has changed SHA to: "Synchronize the LGPL 2.1 with the version from gnu.org" - SDL 1.2 has been removed, along with the --with-sdlabi command line arg - The backported patches have been removed - Al the other patches have been refreshed and the numbering has been updated (From OE-Core rev: fed2a0f37a76732cd3de1b127d6902fb16dd4e05) Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_4.0.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_4.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_4.0.0.bb b/meta/recipes-devtools/qemu/qemu_4.0.0.bb
new file mode 100644
index 0000000000..247e0311ed
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu_4.0.0.bb
@@ -0,0 +1,20 @@
1BBCLASSEXTEND = "nativesdk"
2
3require qemu.inc
4
5DEPENDS = "glib-2.0 zlib pixman"
6
7RDEPENDS_${PN}_class-target += "bash"
8
9EXTRA_OECONF_append_class-target = " --target-list=${@get_qemu_target_list(d)}"
10EXTRA_OECONF_append_class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"
11
12do_install_append_class-nativesdk() {
13 ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)}
14}
15
16PACKAGECONFIG ??= " \
17 fdt sdl kvm \
18 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \
19"
20PACKAGECONFIG_class-nativesdk ??= "fdt sdl kvm"