summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_2.4.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-07 15:35:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-09 14:27:44 +0100
commitfa2f7f996457cb1c506be5584178db250a3b1a2c (patch)
tree7fecad49c78f18ee14360b4348e065336adbc763 /meta/recipes-devtools/qemu/qemu_2.4.0.bb
parentee428e27fed0da8651184cf3ac4a0dd39c4e9d9d (diff)
downloadpoky-fa2f7f996457cb1c506be5584178db250a3b1a2c.tar.gz
qemu: Add fixes for smc91c11 qemu segfaults on arm
The smc91c111.c driver appears to have several issues. The can_receive() function can return that the driver is ready when rx_fifo has not been freed yet. There is also no sanity check of rx_fifo() in _receive() which can lead to corruption of the rx_fifo array. release_packet() can also call qemu_flush_queued_packets() before rx_fifo has been cleaned up, resulting in cases where packets are submitted for which there is not yet any space. This patch therefore: * fixes the logic in can_receive() * adds logic to receive() as a sanity check * moves the flush() calls to the correct places where data is ready to be received Its currently undergoing discussion upstream about exactly which pieces are the correct fix but for now, this stops the segfaults OE is seeing which has to be an improvement. [YOCTO #8234] (From OE-Core rev: 414a5256d6f00d5682ce226ee4bc49674ee6c614) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_2.4.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_2.4.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_2.4.0.bb b/meta/recipes-devtools/qemu/qemu_2.4.0.bb
index 5e5f786b10..d545b60f64 100644
--- a/meta/recipes-devtools/qemu/qemu_2.4.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_2.4.0.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
6SRC_URI += "file://configure-fix-Darwin-target-detection.patch \ 6SRC_URI += "file://configure-fix-Darwin-target-detection.patch \
7 file://qemu-enlarge-env-entry-size.patch \ 7 file://qemu-enlarge-env-entry-size.patch \
8 file://Qemu-Arm-versatilepb-Add-memory-size-checking.patch \ 8 file://Qemu-Arm-versatilepb-Add-memory-size-checking.patch \
9 file://smc91c111_fix.patch \
9 " 10 "
10SRC_URI_prepend = "http://wiki.qemu-project.org/download/${BP}.tar.bz2" 11SRC_URI_prepend = "http://wiki.qemu-project.org/download/${BP}.tar.bz2"
11SRC_URI[md5sum] = "186ee8194140a484a455f8e3c74589f4" 12SRC_URI[md5sum] = "186ee8194140a484a455f8e3c74589f4"