summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_2.10.1.bb
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-10-19 13:10:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-08 22:24:04 +0000
commit1714a598b189027939588d88847a19bbabe72905 (patch)
tree231ea1dd7887991686891743e064061d42586259 /meta/recipes-devtools/qemu/qemu_2.10.1.bb
parent5ae92b6dd3e6635ba5d534369a19b8a5074de51e (diff)
downloadpoky-1714a598b189027939588d88847a19bbabe72905.tar.gz
qemu: upgrade to 2.10.1
All CVE patches removed because these are already integrated in 2.10.1. (From OE-Core rev: ad3e2e2fde557aba0a53bc91d1746518c34b4bd8) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_2.10.1.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_2.10.1.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_2.10.1.bb b/meta/recipes-devtools/qemu/qemu_2.10.1.bb
new file mode 100644
index 0000000000..6e9b68b0ff
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu_2.10.1.bb
@@ -0,0 +1,58 @@
1require qemu.inc
2
3inherit ptest
4
5RDEPENDS_${PN}-ptest = "bash make"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
8 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
9
10SRC_URI = "http://wiki.qemu-project.org/download/${BP}.tar.bz2 \
11 file://powerpc_rom.bin \
12 file://disable-grabs.patch \
13 file://exclude-some-arm-EABI-obsolete-syscalls.patch \
14 file://wacom.patch \
15 file://add-ptest-in-makefile-v10.patch \
16 file://run-ptest \
17 file://qemu-enlarge-env-entry-size.patch \
18 file://no-valgrind.patch \
19 file://pathlimit.patch \
20 file://qemu-2.5.0-cflags.patch \
21 file://glibc-2.25.patch \
22 file://0001-Provide-support-for-the-CUSE-TPM.patch \
23 file://0002-Introduce-condition-to-notify-waiters-of-completed-c.patch \
24 file://0003-Introduce-condition-in-TPM-backend-for-notification.patch \
25 file://0004-Add-support-for-VM-suspend-resume-for-TPM-TIS-v2.9.patch \
26 file://apic-fixup-fallthrough-to-PIC.patch \
27 "
28UPSTREAM_CHECK_REGEX = "qemu-(?P<pver>\d+\..*)\.tar"
29
30
31SRC_URI_append_class-native = " \
32 file://fix-libcap-header-issue-on-some-distro.patch \
33 file://cpus.c-qemu_cpu_kick_thread_debugging.patch \
34 "
35
36SRC_URI[md5sum] = "b375373f688bea0cd8865b966dad15e3"
37SRC_URI[sha256sum] = "8e040bc7556401ebb3a347a8f7878e9d4028cf71b2744b1a1699f4e741966ba8"
38
39COMPATIBLE_HOST_mipsarchn32 = "null"
40COMPATIBLE_HOST_mipsarchn64 = "null"
41
42do_install_append() {
43 # Prevent QA warnings about installed ${localstatedir}/run
44 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
45 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
46}
47
48do_compile_ptest() {
49 make buildtest-TESTS
50}
51
52do_install_ptest() {
53 cp -rL ${B}/tests ${D}${PTEST_PATH}
54 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
55
56 cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
57}
58