summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_0.13.0.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-01-15 16:32:15 +0800
committerSaul Wold <sgw@linux.intel.com>2011-01-21 01:36:14 -0800
commit576e136d9d6d473ce6a7ffc7abadc75e1a218418 (patch)
tree1a3498eddb2ad99d0a864389d0d011b6c828fecc /meta/recipes-devtools/qemu/qemu_0.13.0.bb
parent7d9a8fc931966012a9ddd50e607c6de1d94fe394 (diff)
downloadpoky-576e136d9d6d473ce6a7ffc7abadc75e1a218418.tar.gz
qemu: Upgrade from 0.12.4 to 0.13.0
Patch status: -- Removed -- arm-cp15-fix.patch arm_timer-fix-oneshot-mode.patch arm_timer-reload-timer-when-enabled.patch cursor-shadow-fix.patch -- They are already in upstream or some new changes make them useless. -- Added -- parallel_make.patch: Fix "make -j(>=6)" failure wacom-tablet-fix.patch: Fix seg fault of usb tablet. port92_fix.patch: Fix boot failure on ppc due to port 0x92 conflict. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_0.13.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_0.13.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_0.13.0.bb b/meta/recipes-devtools/qemu/qemu_0.13.0.bb
new file mode 100644
index 0000000000..945c570f7c
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu_0.13.0.bb
@@ -0,0 +1,39 @@
1require qemu.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
4 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
5
6PR = "r0"
7
8FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
9FILESDIR = "${WORKDIR}"
10
11SRC_URI = "\
12 http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz \
13 file://workaround_bad_futex_headers.patch \
14 file://qemu-git-qemugl-host.patch \
15 file://no-strip.patch \
16 file://fix-dirent.patch \
17 file://fix-nogl.patch \
18 file://qemugl-allow-glxcontext-release.patch \
19 file://linker-flags.patch \
20 file://init-info.patch \
21 file://qemu-vmware-vga-depth.patch \
22 file://qemu-ppc-hack.patch \
23 file://enable-i386-linux-user.patch \
24 file://vmware-vga-fifo-rewind.patch \
25 file://fix-configure-checks.patch \
26 file://parallel_make.patch \
27 file://wacom-tablet-fix.patch \
28 file://port92_fix.patch \
29 file://powerpc_rom.bin"
30
31SRC_URI[md5sum] = "397a0d665da8ba9d3b9583629f3d6421"
32SRC_URI[sha256sum] = "1e6f5851b05cea6e377c835f4668408d4124cfb845f9948d922808743c5fd877"
33
34do_install_append () {
35 install -d ${D}${datadir}/qemu
36 install -m 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
37}
38
39S = "${WORKDIR}/qemu-${PV}"