summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-05 23:00:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-09 09:09:49 +0000
commit0d298198e57753213391788a8a9204d99648636b (patch)
tree043c08668b5e30472f230bf41b7837382d3636ac /meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb
parent10c69538c0cb8708c7eff9e8dc05ca7c669cb61c (diff)
downloadpoky-0d298198e57753213391788a8a9204d99648636b.tar.gz
qemu: Upgrade 5.1.0->5.2.0
This involves some pretty major changes for qemu. In particular, they switched to meson+ninja so we have to adapt to that. Patch changes: * CVE patches - dropped as backports * cflags fix - upstream code changed significantly, need new patch if still issues * mips TLB entries - dropped as merged upstream * usb fix - dropped as merged upstream * find_datadir - dropped as code no longer present that I could find A patch was added to allow us to force the configure script into "cross" mode without setting cross_prefix which has other effects we don't need/want. Dependencies on meson/ninja were added. Specifying the python interpreter causes the internal meson copy to be built/used which is undesireable for us so don't do that. The correct python is in PATH anyway. Acked-by: Alistair Francis <alistair.francis@wdc.com> (From OE-Core rev: 181c635567aafb9b4787d8d6d0bcd4a615ceae80) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb b/meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb
new file mode 100644
index 0000000000..222b55cbc6
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb
@@ -0,0 +1,26 @@
1BPN = "qemu"
2
3require qemu-native.inc
4
5# As some of the files installed by qemu-native and qemu-system-native
6# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
8DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native"
9
10EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
11
12PACKAGECONFIG ??= "fdt alsa kvm \
13 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '', d)} \
14"
15
16# Handle distros such as CentOS 5 32-bit that do not have kvm support
17PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
18
19do_install_append() {
20 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
21
22 # The following is also installed by qemu-native
23 rm -f ${D}${datadir}/qemu/trace-events-all
24 rm -rf ${D}${datadir}/qemu/keymaps
25 rm -rf ${D}${datadir}/icons/
26}