summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-10-29 10:47:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-30 13:47:55 +0000
commit4e1e733e06b88a6d8344100c0229c371f00425f7 (patch)
tree29c625431c0d7d96b9eab95ba9d34d3c7505a44f /meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb
parent9111972adbfb90898ef449b4600eabbe501a55f6 (diff)
downloadpoky-4e1e733e06b88a6d8344100c0229c371f00425f7.tar.gz
qemu: update to 3.1.1.1
bug fix only update. Drop patches included in update. For full set of changes, see: https://git.qemu.org/?p=qemu.git;a=shortlog;h=refs/tags/v3.1.1.1 (From OE-Core rev: 14f04e6b6c1fa40a1c39cd186627b4b8442f2d5e) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb b/meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb
new file mode 100644
index 0000000000..5bf528bec1
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb
@@ -0,0 +1,23 @@
1BPN = "qemu"
2
3require qemu-native.inc
4
5# As some of the files installed by qemu-native and qemu-system-native
6# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
8DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native"
9
10EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
11
12PACKAGECONFIG ??= "fdt alsa kvm"
13
14# Handle distros such as CentOS 5 32-bit that do not have kvm support
15PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
16
17do_install_append() {
18 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
19
20 # The following is also installed by qemu-native
21 rm -f ${D}${datadir}/qemu/trace-events-all
22 rm -rf ${D}${datadir}/qemu/keymaps
23}