diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2019-02-27 18:47:31 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-02-28 13:21:54 +0000 |
commit | 48522906a261f9a552f13b146aa7f3691be37002 (patch) | |
tree | a40226291f277540547ebd1c637de5d203cd2378 /meta/recipes-devtools/qemu/qemu-system-native_3.1.0.bb | |
parent | 80d29f1cb1e077cc457a6917fa57561a88921fca (diff) | |
download | poky-48522906a261f9a552f13b146aa7f3691be37002.tar.gz |
qemu: split the native version into usermode and system parts
The rationale is to streamline the overall build.
The system parts are only needed to run target images, and so can be
built towards the end of the build process. At the same time, the
system parts may need gtk+-native and mesa-native which add significantly
to the build time.
On the other hand, the usermode parts have almost no dependencies
and can be built quickly. They are needed at recipes build time to
run target binaries, and so are required quite early in the typical
build process.
(From OE-Core rev: 4a558a5f2db68538e0edad798ddf48eb9510a7d6)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-system-native_3.1.0.bb')
-rw-r--r-- | meta/recipes-devtools/qemu/qemu-system-native_3.1.0.bb | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_3.1.0.bb b/meta/recipes-devtools/qemu/qemu-system-native_3.1.0.bb new file mode 100644 index 0000000000..5bf528bec1 --- /dev/null +++ b/meta/recipes-devtools/qemu/qemu-system-native_3.1.0.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | BPN = "qemu" | ||
2 | |||
3 | require qemu-native.inc | ||
4 | |||
5 | # As some of the files installed by qemu-native and qemu-system-native | ||
6 | # are the same, we depend on qemu-native to get the full installation set | ||
7 | # and avoid file clashes | ||
8 | DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native" | ||
9 | |||
10 | EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}" | ||
11 | |||
12 | PACKAGECONFIG ??= "fdt alsa kvm" | ||
13 | |||
14 | # Handle distros such as CentOS 5 32-bit that do not have kvm support | ||
15 | PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" | ||
16 | |||
17 | do_install_append() { | ||
18 | install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu | ||
19 | |||
20 | # The following is also installed by qemu-native | ||
21 | rm -f ${D}${datadir}/qemu/trace-events-all | ||
22 | rm -rf ${D}${datadir}/qemu/keymaps | ||
23 | } | ||