summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-22 17:43:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-02 05:52:06 -0700
commitad23395cd1f6c0cbfcc6980b6071d589f9f6cde0 (patch)
tree9965e27a93c73af1ccf9cdb24c588faabc90370a /meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
parent58a8a38aa294edb74dde70d70a7e5faf49444b78 (diff)
downloadpoky-ad23395cd1f6c0cbfcc6980b6071d589f9f6cde0.tar.gz
nativesdk: Switch to using nativesdk as a prefix, not a suffix
As discussed on the mailing lists, using a suffix to package names is hard and has lead to many recipes having to do PKGSUFFIX games. Its looking extremely hard to scale nativesdk much further without hacking many recipes. By comparison, using a prefix like multilib does works much better and doesn't involve "hacking" as many recipes. This change converts nativesdk to use a prefix using the existing multilib infrastructure. (From OE-Core rev: 81813c0e322dc04ce4b069117188d8a54dfddb8c) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
new file mode 100644
index 0000000000..fbf9e771df
--- /dev/null
+++ b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Qemu helper scripts"
2DESCRIPTION = "Qemu helper scripts"
3LICENSE = "GPLv2"
4RDEPENDS_${PN} = "nativesdk-qemu"
5PR = "r9"
6
7FILESPATH = "${FILE_DIRNAME}/qemu-helper"
8
9LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999 \
10 file://${COREBASE}/scripts/runqemu;endline=18;md5=77fbe442a88b1bcdc29c3ba67733b21b"
11
12
13SRC_URI = "file://${COREBASE}/scripts/runqemu \
14 file://${COREBASE}/scripts/runqemu-internal \
15 file://${COREBASE}/scripts/runqemu-addptable2image \
16 file://${COREBASE}/scripts/runqemu-gen-tapdevs \
17 file://${COREBASE}/scripts/runqemu-ifup \
18 file://${COREBASE}/scripts/runqemu-ifdown \
19 file://${COREBASE}/scripts/oe-find-native-sysroot \
20 file://${COREBASE}/scripts/runqemu-extract-sdk \
21 file://${COREBASE}/scripts/runqemu-export-rootfs \
22 file://tunctl.c \
23 file://raw2flash.c \
24 "
25
26S = "${WORKDIR}"
27
28inherit nativesdk
29
30do_compile() {
31 ${CC} tunctl.c -o tunctl
32 ${CC} raw2flash.c -o raw2flash.spitz
33 ${CC} raw2flash.c -o flash2raw.spitz -Dflash2raw
34}
35
36do_install() {
37 install -d ${D}${bindir}
38 install -m 0755 ${WORKDIR}${COREBASE}/scripts/oe-* ${D}${bindir}/
39 install -m 0755 ${WORKDIR}${COREBASE}/scripts/runqemu* ${D}${bindir}/
40 install tunctl ${D}${bindir}/
41 install raw2flash.spitz ${D}${bindir}/
42 install flash2raw.spitz ${D}${bindir}/
43 ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.akita
44 ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.borzoi
45 ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.terrier
46 ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.akita
47 ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.borzoi
48 ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.terrier
49}