diff options
author | Yue Tao <Yue.Tao@windriver.com> | 2013-11-28 16:34:48 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-12-03 17:45:51 +0000 |
commit | 68d40e29a741da3a0ed502cd8c5da788d061046f (patch) | |
tree | 09a019736d046076525a9874b21a09a711dacb3b /meta/recipes-devtools/python/python_2.7.3.bb | |
parent | d4398d41be6974d57e834cc9737348ba13e10547 (diff) | |
download | poky-68d40e29a741da3a0ed502cd8c5da788d061046f.tar.gz |
python: do not replace ccache in the middle of a path
Python recipe did a sed s/ccache/$(CCACHE) on the Makefile, which
replaces all "ccache" including ones that consist of a full path.
This leads to build error when building in a project path with
"ccache" in its name. Fix it by only replacing "ccache " with
"$(CCACHE) ".
(From OE-Core rev: 1181112cf65bc0186807fc59399c5dddcb9f9449)
Signed-off-by: Lei Liu <lei.liu2@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r-- | meta/recipes-devtools/python/python_2.7.3.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb index 887e02e1c3..b560b82754 100644 --- a/meta/recipes-devtools/python/python_2.7.3.bb +++ b/meta/recipes-devtools/python/python_2.7.3.bb | |||
@@ -61,7 +61,7 @@ do_compile() { | |||
61 | cd - | 61 | cd - |
62 | 62 | ||
63 | # remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144 | 63 | # remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144 |
64 | sed -i -e s,ccache,'$(CCACHE)', Makefile | 64 | sed -i -e s,ccache\ ,'$(CCACHE) ', Makefile |
65 | 65 | ||
66 | # remove any bogus LD_LIBRARY_PATH | 66 | # remove any bogus LD_LIBRARY_PATH |
67 | sed -i -e s,RUNSHARED=.*,RUNSHARED=, Makefile | 67 | sed -i -e s,RUNSHARED=.*,RUNSHARED=, Makefile |