diff options
author | Morgan Little <morgan.little@windriver.com> | 2012-07-19 13:46:07 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-07-22 11:42:20 +0100 |
commit | 75b7c51fed6e3b48c191af41f89192a86659058d (patch) | |
tree | bf376152bcfe2e30bd5f87d13fe264028deed7d4 /meta/recipes-devtools/python/python_2.7.3.bb | |
parent | 093ed41b0f0d89cb6344acdf6bb62cb9ca597f2f (diff) | |
download | poky-75b7c51fed6e3b48c191af41f89192a86659058d.tar.gz |
python: Update for python-native changes
Add pythonnative onto the list of inherits and update the paths to the binaries
referenced in the recipe to the new paths.
(From OE-Core rev: 284a65d55f0ffad0f4f7f32d72da0f9410578643)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r-- | meta/recipes-devtools/python/python_2.7.3.bb | 18 |
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb index b736cc2b5e..d27ff05a18 100644 --- a/meta/recipes-devtools/python/python_2.7.3.bb +++ b/meta/recipes-devtools/python/python_2.7.3.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | require python.inc | 1 | require python.inc |
2 | DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib" | 2 | DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib" |
3 | PR = "${INC_PR}.0" | 3 | PR = "${INC_PR}.1" |
4 | 4 | ||
5 | DISTRO_SRC_URI ?= "file://sitecustomize.py" | 5 | DISTRO_SRC_URI ?= "file://sitecustomize.py" |
6 | DISTRO_SRC_URI_linuxstdbase = "" | 6 | DISTRO_SRC_URI_linuxstdbase = "" |
@@ -30,7 +30,7 @@ SRC_URI += "\ | |||
30 | 30 | ||
31 | S = "${WORKDIR}/Python-${PV}" | 31 | S = "${WORKDIR}/Python-${PV}" |
32 | 32 | ||
33 | inherit autotools multilib_header | 33 | inherit autotools multilib_header pythonnative |
34 | 34 | ||
35 | # The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources | 35 | # The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources |
36 | #Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :( | 36 | #Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :( |
@@ -45,7 +45,7 @@ do_configure_prepend() { | |||
45 | do_compile() { | 45 | do_compile() { |
46 | # regenerate platform specific files, because they depend on system headers | 46 | # regenerate platform specific files, because they depend on system headers |
47 | cd Lib/plat-linux2 | 47 | cd Lib/plat-linux2 |
48 | include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python \ | 48 | include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python-native/python \ |
49 | ${S}/Tools/scripts/h2py.py -i '(u_long)' \ | 49 | ${S}/Tools/scripts/h2py.py -i '(u_long)' \ |
50 | ${STAGING_INCDIR}/dlfcn.h \ | 50 | ${STAGING_INCDIR}/dlfcn.h \ |
51 | ${STAGING_INCDIR}/linux/cdrom.h \ | 51 | ${STAGING_INCDIR}/linux/cdrom.h \ |
@@ -89,8 +89,8 @@ do_compile() { | |||
89 | 89 | ||
90 | export CROSS_COMPILE="${TARGET_PREFIX}" | 90 | export CROSS_COMPILE="${TARGET_PREFIX}" |
91 | 91 | ||
92 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \ | 92 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \ |
93 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \ | 93 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \ |
94 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | 94 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
95 | STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \ | 95 | STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \ |
96 | STAGING_INCDIR=${STAGING_INCDIR} \ | 96 | STAGING_INCDIR=${STAGING_INCDIR} \ |
@@ -99,8 +99,8 @@ do_compile() { | |||
99 | 99 | ||
100 | oe_libinstall -so libpython${PYTHON_MAJMIN} ${STAGING_LIBDIR} | 100 | oe_libinstall -so libpython${PYTHON_MAJMIN} ${STAGING_LIBDIR} |
101 | 101 | ||
102 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \ | 102 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \ |
103 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \ | 103 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \ |
104 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | 104 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
105 | STAGING_INCDIR=${STAGING_INCDIR} \ | 105 | STAGING_INCDIR=${STAGING_INCDIR} \ |
106 | STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \ | 106 | STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \ |
@@ -115,8 +115,8 @@ do_install() { | |||
115 | 115 | ||
116 | export CROSS_COMPILE="${TARGET_PREFIX}" | 116 | export CROSS_COMPILE="${TARGET_PREFIX}" |
117 | 117 | ||
118 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \ | 118 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \ |
119 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \ | 119 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \ |
120 | CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ \ | 120 | CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ \ |
121 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | 121 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
122 | STAGING_INCDIR=${STAGING_INCDIR} \ | 122 | STAGING_INCDIR=${STAGING_INCDIR} \ |