summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.2.bb
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-04-05 23:54:21 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-31 21:15:10 +0100
commitd1bc1191d69ca17ad8287a2708e16f58e7a73e7d (patch)
treea70ef3a7a30c3a3e2b250ec761137a0a32e9574f /meta/recipes-devtools/python/python_2.7.2.bb
parent5c507a2fd7514a943b950fb0b2134c3fa3c4419a (diff)
downloadpoky-d1bc1191d69ca17ad8287a2708e16f58e7a73e7d.tar.gz
python: Add patch for 64bit platform
This patch was added for 64bit host machines. In the compile process python is checking if platform is a 64bit platform using sys.maxint which is the host's value. The patch fixes this issue so that python would check if TARGET machine is 64bit not the HOST machine. In this way will have "dl" and "imageop" modules built if HOST machine is 64bit but the target machine is 32bit. [YOCTO #1937] (From OE-Core rev: 22ae3959f40845ebcc00413ccf733539472a1a81) Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index 9ba561b18b..bfe3ee02f8 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -1,6 +1,6 @@
1require python.inc 1require python.inc
2DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib" 2DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
3PR = "${INC_PR}.15" 3PR = "${INC_PR}.16"
4 4
5DISTRO_SRC_URI ?= "file://sitecustomize.py" 5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = "" 6DISTRO_SRC_URI_linuxstdbase = ""
@@ -22,6 +22,7 @@ SRC_URI += "\
22 file://sys_platform_is_now_always_linux2.patch \ 22 file://sys_platform_is_now_always_linux2.patch \
23 file://fix_for_using_different_libdir.patch \ 23 file://fix_for_using_different_libdir.patch \
24 file://setuptweaks.patch \ 24 file://setuptweaks.patch \
25 file://check-if-target-is-64b-not-host.patch \
25" 26"
26 27
27S = "${WORKDIR}/Python-${PV}" 28S = "${WORKDIR}/Python-${PV}"