summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.2.bb
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2012-03-12 22:24:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-13 11:45:13 +0000
commitc7ac3f49cdb97d3c65b7991a8c861f8dbb3d94a0 (patch)
treebf311121c455825b3631816610437b3597b615c1 /meta/recipes-devtools/python/python_2.7.2.bb
parentc8f2f585fc653db728e44812246d16ed8ae993d2 (diff)
downloadpoky-c7ac3f49cdb97d3c65b7991a8c861f8dbb3d94a0.tar.gz
python: regenerate plat-linux2/*.py
* If plat-linux2/DLFCN.py was present, python was broken in our image, i.e. it was unable to load many modules. This was due to changed RTLD_* constants in dlfcn.h * Python includes a script, plat-linux2/regen, to regenerate the py source codes in this directory. * Do what plat-linux2/regen would do, but use files from STAGING_INCDIR. (From OE-Core rev: 3bb9d027fff925a40c4dea9109df9464a76853b7) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index 5ad410904f..0a8e53494d 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -37,6 +37,17 @@ do_configure_prepend() {
37} 37}
38 38
39do_compile() { 39do_compile() {
40 # regenerate platform specific files, because they depend on system headers
41 cd Lib/plat-linux2
42 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python \
43 ${S}/Tools/scripts/h2py.py -i '(u_long)' \
44 ${STAGING_INCDIR}/dlfcn.h \
45 ${STAGING_INCDIR}/linux/cdrom.h \
46 ${STAGING_INCDIR}/netinet/in.h \
47 ${STAGING_INCDIR}/sys/types.h
48 sed -e 's,${STAGING_DIR_HOST},,g' -i *.py
49 cd -
50
40 # 51 #
41 # Copy config.h and an appropriate Makefile for distutils.sysconfig, 52 # Copy config.h and an appropriate Makefile for distutils.sysconfig,
42 # which laters uses the information out of these to compile extensions 53 # which laters uses the information out of these to compile extensions