summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.2.bb
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2012-04-08 22:01:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-11 12:48:37 +0100
commitf03d66bcc1fde80fd8923a400d2f2edfee576068 (patch)
tree1cd765229b939537888d879045cd9909f098be58 /meta/recipes-devtools/python/python_2.7.2.bb
parentb23b2b42a0c1ff6243227cb7d38c8cb6ae388bcf (diff)
downloadpoky-f03d66bcc1fde80fd8923a400d2f2edfee576068.tar.gz
python: multilib header support.
Add intercept multilib header for pyconfig.h in python. This is part of the bug fixing [YOCTO #2216]. (From OE-Core rev: 99591085186c465f2ddfaef08f419ec7584d4522) Signed-off-by: Lianhao Lu <lianhao.lu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index 53e994f4b5..d1d0d83b75 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -25,7 +25,7 @@ SRC_URI += "\
25 25
26S = "${WORKDIR}/Python-${PV}" 26S = "${WORKDIR}/Python-${PV}"
27 27
28inherit autotools 28inherit autotools multilib_header
29 29
30# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources 30# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources
31#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :( 31#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :(
@@ -113,6 +113,8 @@ do_install() {
113 if [ -e ${WORKDIR}/sitecustomize.py ]; then 113 if [ -e ${WORKDIR}/sitecustomize.py ]; then
114 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN} 114 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
115 fi 115 fi
116
117 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
116} 118}
117 119
118SSTATE_SCAN_FILES += "Makefile" 120SSTATE_SCAN_FILES += "Makefile"