diff options
author | Ross Burton <ross.burton@intel.com> | 2018-10-15 19:13:01 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-10-16 20:35:43 +0100 |
commit | 04370c671eafb193d03ed1d48584c6aa218965ae (patch) | |
tree | f4bfe4410fee017b3a49cc6edf9d254bc9ebcc7e /meta/recipes-devtools/python/python_2.7.15.bb | |
parent | 2b5d32596b766c4d1dbbc18d8dd879d19950ef82 (diff) | |
download | poky-04370c671eafb193d03ed1d48584c6aa218965ae.tar.gz |
python: don't wipe RDEPENDS when parsing manifest
We want to allow the main recipe to extend RDEPENDS directly, so don't wipe
RDEPENDS when reading the manifest.
This fixes the missing python-misc dependency from python-modules.
As the wiping was having the good side-effect of removing the PN-dev dependency
on PN (which doesn't exist), clear RDEPENDS_${PN}-dev.
(From OE-Core rev: fe3727af217dce4488f1fc6aab3f66232cf11fea)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.15.bb')
-rw-r--r-- | meta/recipes-devtools/python/python_2.7.15.bb | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.15.bb b/meta/recipes-devtools/python/python_2.7.15.bb index e3a4ddb327..d78400b6e6 100644 --- a/meta/recipes-devtools/python/python_2.7.15.bb +++ b/meta/recipes-devtools/python/python_2.7.15.bb | |||
@@ -177,6 +177,8 @@ FILES_${PN}-man = "${datadir}/man" | |||
177 | # Nasty but if bdb isn't enabled the package won't be generated | 177 | # Nasty but if bdb isn't enabled the package won't be generated |
178 | RDEPENDS_${PN}-modules_remove = "${@bb.utils.contains('PACKAGECONFIG', 'bdb', '', '${PN}-bsddb', d)}" | 178 | RDEPENDS_${PN}-modules_remove = "${@bb.utils.contains('PACKAGECONFIG', 'bdb', '', '${PN}-bsddb', d)}" |
179 | 179 | ||
180 | RDEPENDS_${PN}-dev = "" | ||
181 | |||
180 | BBCLASSEXTEND = "nativesdk" | 182 | BBCLASSEXTEND = "nativesdk" |
181 | 183 | ||
182 | RPROVIDES_${PN} += "${PN}-modules" | 184 | RPROVIDES_${PN} += "${PN}-modules" |
@@ -220,7 +222,6 @@ python(){ | |||
220 | if value.endswith('.py'): | 222 | if value.endswith('.py'): |
221 | d.appendVar('FILES_' + pypackage, ' ' + value + 'c') | 223 | d.appendVar('FILES_' + pypackage, ' ' + value + 'c') |
222 | 224 | ||
223 | d.setVar('RDEPENDS_' + pypackage, '') | ||
224 | for value in python_manifest[key]['rdepends']: | 225 | for value in python_manifest[key]['rdepends']: |
225 | # Make it work with or without $PN | 226 | # Make it work with or without $PN |
226 | if '${PN}' in value: | 227 | if '${PN}' in value: |