summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.15.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-10-12 12:55:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-14 09:20:56 +0100
commit64ff0a5e6c76803e76256d941acbe574ad2a33d8 (patch)
treefd3a29830e2ef50e4c373aa5aab2907e843b9e1e /meta/recipes-devtools/python/python_2.7.15.bb
parent273af8144e05bcba20adad6cad3886bd97f7bbaf (diff)
downloadpoky-64ff0a5e6c76803e76256d941acbe574ad2a33d8.tar.gz
python: clean up ptest
As the manifest handling is done differently now, just inherit ptest with the other inherits. test_shutil needs unzip so add to RDEPENDS. Instead of using a patched Makefile, call test.regrtest directly. (From OE-Core rev: 84f34ad223b1e3f36cab2ac12246eb90efc919bc) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.15.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.15.bb25
1 files changed, 2 insertions, 23 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.15.bb b/meta/recipes-devtools/python/python_2.7.15.bb
index 472c1da4bf..e7010bb689 100644
--- a/meta/recipes-devtools/python/python_2.7.15.bb
+++ b/meta/recipes-devtools/python/python_2.7.15.bb
@@ -24,7 +24,6 @@ SRC_URI += "\
24 file://avoid_warning_about_tkinter.patch \ 24 file://avoid_warning_about_tkinter.patch \
25 file://avoid_warning_for_sunos_specific_module.patch \ 25 file://avoid_warning_for_sunos_specific_module.patch \
26 file://python-2.7.3-remove-bsdb-rpath.patch \ 26 file://python-2.7.3-remove-bsdb-rpath.patch \
27 file://fix-makefile-for-ptest.patch \
28 file://run-ptest \ 27 file://run-ptest \
29 file://parallel-makeinst-create-bindir.patch \ 28 file://parallel-makeinst-create-bindir.patch \
30 file://use_sysroot_ncurses_instead_of_host.patch \ 29 file://use_sysroot_ncurses_instead_of_host.patch \
@@ -35,7 +34,7 @@ SRC_URI += "\
35 34
36S = "${WORKDIR}/Python-${PV}" 35S = "${WORKDIR}/Python-${PV}"
37 36
38inherit autotools multilib_header python-dir pythonnative 37inherit autotools multilib_header python-dir pythonnative ptest
39 38
40CONFIGUREOPTS += " --with-system-ffi " 39CONFIGUREOPTS += " --with-system-ffi "
41 40
@@ -168,27 +167,7 @@ FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
168RDEPENDS_${PN}-modules += "${PN}-misc" 167RDEPENDS_${PN}-modules += "${PN}-misc"
169 168
170# ptest 169# ptest
171RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests" 170RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip"
172#inherit ptest after "require python-${PYTHON_MAJMIN}-manifest.inc" so PACKAGES doesn't get overwritten
173inherit ptest
174
175# This must come after inherit ptest for the override to take effect
176do_install_ptest() {
177 cp ${B}/Makefile ${D}${PTEST_PATH}
178 sed -e s:LIBDIR/python/ptest:${PTEST_PATH}:g \
179 -e s:LIBDIR:${libdir}:g \
180 -i ${D}${PTEST_PATH}/run-ptest
181
182 #Remove build host references
183 sed -i \
184 -e 's:--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
185 -e 's:--sysroot=${STAGING_DIR_TARGET}::g' \
186 -e 's|${DEBUG_PREFIX_MAP}||g' \
187 -e 's:${HOSTTOOLS_DIR}/::g' \
188 -e 's:${RECIPE_SYSROOT}::g' \
189 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
190 ${D}/${PTEST_PATH}/Makefile
191}
192 171
193# catch manpage 172# catch manpage
194PACKAGES += "${PN}-man" 173PACKAGES += "${PN}-man"