diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2011-05-25 14:40:05 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-05-25 15:58:46 +0100 |
commit | 4da5ff75f722c6a54312b78b41b6dcc38a61a969 (patch) | |
tree | d2b9f539daa43dab63c183baa2c27465931ca283 /meta/recipes-devtools/python/python_2.6.6.bb | |
parent | b543da36dec8f1ae45ff536b439317dd4ef70346 (diff) | |
download | poky-4da5ff75f722c6a54312b78b41b6dcc38a61a969.tar.gz |
python-2.6.6: py_package_preprocess should change Makefile only in PKGD not D
* PACKAGEFUNCS ?= "perform_packagecopy \
${PACKAGE_PREPROCESS_FUNCS} \
our py_package_preprocess is called after perform_packagecopy which does copy D to PKGD
so we change it to target version in D (image/) before populating sysroot (sysroot-destdir/)
while keeping Makefile.sysroot version in PKGD which was created before calling
py_package_preprocess, so both package for runtime and sysroot end wrong
* I haven't seen this problem on faster builder, I guess because do_package and do_populate_sysroot
can run in paralell and I was lucky that do_populate_sysroot finished before py_package_preprocess
was started, but if you build python step by step -c package first you should see it every time
* here is proof that with PKGD it works better:
$ bitbake -c cleanall python
$ bitbake -c install python
$ grep LIBDIR= \
./packages-split/python-distutils/usr/lib/python2.6/config/Makefile \
./package/usr/lib/python2.6/config/Makefile \
./sysroot-destdir/usr/lib/python2.6/config/Makefile \
./image/usr/lib/python2.6/config/Makefile \
./Python-2.6.6/Makefile \
~/shr-core/tmp/sysroots/om-gta02/usr/lib/python2.6/config/Makefile
grep: ./packages-split/python-distutils/usr/lib/python2.6/config/Makefile: No such file or directory
grep: ./package/usr/lib/python2.6/config/Makefile: No such file or directory
grep: ./sysroot-destdir/usr/lib/python2.6/config/Makefile: No such file or directory
./image/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
./Python-2.6.6/Makefile:LIBDIR= /usr/lib
/OE/shr-core/tmp/sysroots/om-gta02/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
$ bitbake -c package python
$ grep LIBDIR= \
./packages-split/python-distutils/usr/lib/python2.6/config/Makefile \
./package/usr/lib/python2.6/config/Makefile \
./sysroot-destdir/usr/lib/python2.6/config/Makefile \
./image/usr/lib/python2.6/config/Makefile \
./Python-2.6.6/Makefile \
~/shr-core/tmp/sysroots/om-gta02/usr/lib/python2.6/config/Makefile
./packages-split/python-distutils/usr/lib/python2.6/config/Makefile:LIBDIR= /usr/lib
./package/usr/lib/python2.6/config/Makefile:LIBDIR= /usr/lib
grep: ./sysroot-destdir/usr/lib/python2.6/config/Makefile: No such file or directory
./image/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
./Python-2.6.6/Makefile:LIBDIR= /usr/lib
/OE/shr-core/tmp/sysroots/om-gta02/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
$ bitbake -c package python
$ grep LIBDIR= \
./packages-split/python-distutils/usr/lib/python2.6/config/Makefile \
./package/usr/lib/python2.6/config/Makefile \
./sysroot-destdir/usr/lib/python2.6/config/Makefile \
./image/usr/lib/python2.6/config/Makefile \
./Python-2.6.6/Makefile \
~/shr-core/tmp/sysroots/om-gta02/usr/lib/python2.6/config/Makefile
./packages-split/python-distutils/usr/lib/python2.6/config/Makefile:LIBDIR= /usr/lib
./package/usr/lib/python2.6/config/Makefile:LIBDIR= /usr/lib
./sysroot-destdir/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
./image/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
./Python-2.6.6/Makefile:LIBDIR= /usr/lib
/OE/shr-core/tmp/sysroots/om-gta02/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
* without this patch we have /usr/lib/ in image/sysroot-destdir and SYSROOT_LIBDIR in package/packages-split
$ grep LIBDIR= \
./packages-split/python-distutils/usr/lib/python2.6/config/Makefile \
./package/usr/lib/python2.6/config/Makefile \
./sysroot-destdir/usr/lib/python2.6/config/Makefile \
./image/usr/lib/python2.6/config/Makefile \
./Python-2.6.6/Makefile \
~/shr-core/tmp/sysroots/om-gta02/usr/lib/python2.6/config/Makefile
./packages-split/python-distutils/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
./package/usr/lib/python2.6/config/Makefile:LIBDIR= /OE/shr-core/tmp/sysroots/om-gta02/usr/lib
./sysroot-destdir/usr/lib/python2.6/config/Makefile:LIBDIR= /usr/lib
./image/usr/lib/python2.6/config/Makefile:LIBDIR= /usr/lib
./Python-2.6.6/Makefile:LIBDIR= /usr/lib
/OE/shr-core/tmp/sysroots/om-gta02/usr/lib/python2.6/config/Makefile:LIBDIR= /usr/lib
(From OE-Core rev: 2ba5ce85dcc3c6812b10073bfc4ab600ca169df1)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.6.6.bb')
-rw-r--r-- | meta/recipes-devtools/python/python_2.6.6.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python_2.6.6.bb b/meta/recipes-devtools/python/python_2.6.6.bb index 65875ff34a..24f1d33166 100644 --- a/meta/recipes-devtools/python/python_2.6.6.bb +++ b/meta/recipes-devtools/python/python_2.6.6.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | require python.inc | 1 | require python.inc |
2 | DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib" | 2 | DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib" |
3 | DEPENDS_sharprom = "python-native db readline zlib gdbm openssl" | 3 | DEPENDS_sharprom = "python-native db readline zlib gdbm openssl" |
4 | PR = "${INC_PR}.3" | 4 | PR = "${INC_PR}.4" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6" |
6 | 6 | ||
7 | DISTRO_SRC_URI ?= "file://sitecustomize.py" | 7 | DISTRO_SRC_URI ?= "file://sitecustomize.py" |
@@ -96,7 +96,7 @@ PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess" | |||
96 | 96 | ||
97 | py_package_preprocess () { | 97 | py_package_preprocess () { |
98 | # copy back the old Makefile to fix target package | 98 | # copy back the old Makefile to fix target package |
99 | install -m 0644 Makefile.orig ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile | 99 | install -m 0644 Makefile.orig ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile |
100 | } | 100 | } |
101 | 101 | ||
102 | require python-${PYTHON_MAJMIN}-manifest.inc | 102 | require python-${PYTHON_MAJMIN}-manifest.inc |