summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.7.8.bb
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2020-07-09 00:07:43 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-04 23:17:37 +0100
commit33bab96f787715532cc4912076c71e5d063e5df5 (patch)
treeee54f17f24b5b14daf8202bbec32ecb351abb73b /meta/recipes-devtools/python/python3_3.7.8.bb
parenta92ae31dc4f1a124fe3d722c7239796d1b37cbc3 (diff)
downloadpoky-33bab96f787715532cc4912076c71e5d063e5df5.tar.gz
python3: Upgrade 3.7.7 -> 3.7.8
Backported patch removed. (From OE-Core rev: 2c33c482ba6691ae82252f192b3c03e8c8fb7d55) Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.7.8.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.8.bb343
1 files changed, 343 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.8.bb b/meta/recipes-devtools/python/python3_3.7.8.bb
new file mode 100644
index 0000000000..5230fe0ee6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3_3.7.8.bb
@@ -0,0 +1,343 @@
1SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3LICENSE = "PSFv2"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=203a6dbc802ee896020a47161e759642"
7
8SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
9 file://run-ptest \
10 file://create_manifest3.py \
11 file://get_module_deps3.py \
12 file://python3-manifest.json \
13 file://check_build_completeness.py \
14 file://cgi_py.patch \
15 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
16 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
17 file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
18 file://python-config.patch \
19 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
20 file://0001-Do-not-hardcode-lib-as-location-for-site-packages-an.patch \
21 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
22 file://0002-Don-t-do-runtime-test-to-get-float-byte-order.patch \
23 file://0003-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \
24 file://0001-Lib-sysconfig.py-fix-another-place-where-lib-is-hard.patch \
25 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \
26 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
27 file://crosspythonpath.patch \
28 file://reformat_sysconfig.py \
29 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
30 file://0001-test_locale.py-correct-the-test-output-format.patch \
31 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
32 "
33
34SRC_URI_append_class-native = " \
35 file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \
36 file://12-distutils-prefix-is-inside-staging-area.patch \
37 file://0001-Don-t-search-system-for-headers-libraries.patch \
38 "
39SRC_URI_append_class-nativesdk = " \
40 file://0001-main.c-if-OEPYTHON3HOME-is-set-use-instead-of-PYTHON.patch \
41 "
42
43SRC_URI[md5sum] = "a224ef2249a18824f48fba9812f4006f"
44SRC_URI[sha256sum] = "43a543404b363f0037f89df8478f19db2dbc0d6f3ffee310bc2997fa71854a63"
45
46# exclude pre-releases for both python 2.x and 3.x
47UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
48
49CVE_PRODUCT = "python"
50
51# This is not exploitable when glibc has CVE-2016-10739 fixed.
52CVE_CHECK_WHITELIST += "CVE-2019-18348"
53
54PYTHON_MAJMIN = "3.7"
55PYTHON_BINABI = "${PYTHON_MAJMIN}m"
56
57S = "${WORKDIR}/Python-${PV}"
58
59BBCLASSEXTEND = "native nativesdk"
60
61inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
62
63MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
64
65ALTERNATIVE_${PN}-dev = "python-config"
66ALTERNATIVE_LINK_NAME[python-config] = "${bindir}/python${PYTHON_BINABI}-config"
67ALTERNATIVE_TARGET[python-config] = "${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX}"
68
69
70DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux libtirpc libnsl2"
71DEPENDS_append_class-target = " python3-native"
72DEPENDS_append_class-nativesdk = " python3-native"
73
74EXTRA_OECONF = " --without-ensurepip --enable-shared"
75EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}"
76
77export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
78
79EXTRANATIVEPATH += "python3-native"
80
81CACHED_CONFIGUREVARS = " \
82 ac_cv_file__dev_ptmx=yes \
83 ac_cv_file__dev_ptc=no \
84 ac_cv_working_tzset=yes \
85"
86python() {
87 # PGO currently causes builds to not be reproducible, so disable it for
88 # now. See YOCTO #13407
89 if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1':
90 d.setVar('PACKAGECONFIG_PGO', 'pgo')
91 else:
92 d.setVar('PACKAGECONFIG_PGO', '')
93}
94
95PACKAGECONFIG_class-target ??= "readline ${PACKAGECONFIG_PGO} gdbm"
96PACKAGECONFIG_class-native ??= "readline gdbm"
97PACKAGECONFIG_class-nativesdk ??= "readline gdbm"
98PACKAGECONFIG[readline] = ",,readline"
99# Use profile guided optimisation by running PyBench inside qemu-user
100PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
101PACKAGECONFIG[tk] = ",,tk"
102PACKAGECONFIG[gdbm] = ",,gdbm"
103
104do_configure_prepend () {
105 mkdir -p ${B}/Modules
106 cat > ${B}/Modules/Setup.local << EOF
107*disabled*
108${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
109${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
110EOF
111}
112
113CPPFLAGS_append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
114
115EXTRA_OEMAKE = '\
116 STAGING_LIBDIR=${STAGING_LIBDIR} \
117 STAGING_INCDIR=${STAGING_INCDIR} \
118 LIB=${baselib} \
119'
120
121do_compile_prepend_class-target() {
122 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
123 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
124 cat >pgo-wrapper <<EOF
125#!/bin/sh
126cd ${B}
127$qemu_binary "\$@"
128EOF
129 chmod +x pgo-wrapper
130 fi
131}
132
133do_install_prepend() {
134 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
135}
136
137do_install_append_class-target() {
138 oe_multilib_header python${PYTHON_BINABI}/pyconfig.h
139}
140
141do_install_append_class-native() {
142 # Make sure we use /usr/bin/env python
143 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
144 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
145 done
146 # Add a symlink to the native Python so that scripts can just invoke
147 # "nativepython" and get the right one without needing absolute paths
148 # (these often end up too long for the #! parser in the kernel as the
149 # buffer is 128 bytes long).
150 ln -s python3-native/python3 ${D}${bindir}/nativepython3
151}
152
153do_install_append() {
154 mkdir -p ${D}${libdir}/python-sysconfigdata
155 sysconfigfile=`find ${D} -name _sysconfig*.py`
156 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
157
158 sed -i \
159 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
160 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
161 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
162 -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
163 -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
164 ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
165}
166
167do_install_append_class-nativesdk () {
168 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} OEPYTHON3HOME='${prefix}' TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
169}
170
171SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
172PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
173
174py_package_preprocess () {
175 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
176 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
177 -e 's|${DEBUG_PREFIX_MAP}||g' \
178 -e 's:${HOSTTOOLS_DIR}/::g' \
179 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
180 -e 's:${RECIPE_SYSROOT}::g' \
181 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
182 ${PKGD}/${prefix}/lib/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
183 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
184 ${PKGD}/${bindir}/python${PYTHON_BINABI}-config
185
186 # Reformat _sysconfigdata after modifying it so that it remains
187 # reproducible
188 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
189 python3 ${WORKDIR}/reformat_sysconfig.py $c
190 done
191
192 # Recompile _sysconfigdata after modifying it
193 cd ${PKGD}
194 sysconfigfile=`find . -name _sysconfigdata_*.py`
195 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
196 -c "from py_compile import compile; compile('$sysconfigfile')"
197 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
198 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
199 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
200 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
201 cd -
202
203 mv ${PKGD}/${bindir}/python${PYTHON_BINABI}-config ${PKGD}/${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX}
204
205 #Remove the unneeded copy of target sysconfig data
206 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
207}
208
209# We want bytecode precompiled .py files (.pyc's) by default
210# but the user may set it on their own conf
211INCLUDE_PYCS ?= "1"
212
213python(){
214 import collections, json
215
216 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
217 # This python changes the datastore based on the contents of a file, so mark
218 # that dependency.
219 bb.parse.mark_dependency(d, filename)
220
221 with open(filename) as manifest_file:
222 manifest_str = manifest_file.read()
223 json_start = manifest_str.find('# EOC') + 6
224 manifest_file.seek(json_start)
225 manifest_str = manifest_file.read()
226 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
227
228 # First set RPROVIDES for -native case
229 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
230 pn = 'python3'
231 rprovides = d.getVar('RPROVIDES').split()
232
233 for key in python_manifest:
234 pypackage = pn + '-' + key + '-native'
235 if pypackage not in rprovides:
236 rprovides.append(pypackage)
237
238 d.setVar('RPROVIDES_class-native', ' '.join(rprovides))
239
240 # Then work on the target
241 include_pycs = d.getVar('INCLUDE_PYCS')
242
243 packages = d.getVar('PACKAGES').split()
244 pn = d.getVar('PN')
245
246 newpackages=[]
247 for key in python_manifest:
248 pypackage = pn + '-' + key
249
250 if pypackage not in packages:
251 # We need to prepend, otherwise python-misc gets everything
252 # so we use a new variable
253 newpackages.append(pypackage)
254
255 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
256 d.setVar('FILES_' + pypackage, '')
257 for value in python_manifest[key]['files']:
258 d.appendVar('FILES_' + pypackage, ' ' + value)
259
260 # Add cached files
261 if include_pycs == '1':
262 for value in python_manifest[key]['cached']:
263 d.appendVar('FILES_' + pypackage, ' ' + value)
264
265 for value in python_manifest[key]['rdepends']:
266 # Make it work with or without $PN
267 if '${PN}' in value:
268 value=value.split('-', 1)[1]
269 d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
270
271 for value in python_manifest[key].get('rrecommends', ()):
272 if '${PN}' in value:
273 value=value.split('-', 1)[1]
274 d.appendVar('RRECOMMENDS_' + pypackage, ' ' + pn + '-' + value)
275
276 d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
277
278 # Prepending so to avoid python-misc getting everything
279 packages = newpackages + packages
280 d.setVar('PACKAGES', ' '.join(packages))
281 d.setVar('ALLOW_EMPTY_${PN}-modules', '1')
282}
283
284# Files needed to create a new manifest
285
286do_create_manifest() {
287 # This task should be run with every new release of Python.
288 # We must ensure that PACKAGECONFIG enables everything when creating
289 # a new manifest, this is to base our new manifest on a complete
290 # native python build, containing all dependencies, otherwise the task
291 # wont be able to find the required files.
292 # e.g. BerkeleyDB is an optional build dependency so it may or may not
293 # be present, we must ensure it is.
294
295 cd ${WORKDIR}
296 # This needs to be executed by python-native and NOT by HOST's python
297 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
298 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
299}
300
301# bitbake python -c create_manifest
302addtask do_create_manifest
303
304# Make sure we have native python ready when we create a new manifest
305do_create_manifest[depends] += "${PN}:do_prepare_recipe_sysroot"
306do_create_manifest[depends] += "${PN}:do_patch"
307
308# manual dependency additions
309RPROVIDES_${PN}-modules = "${PN}"
310RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
311RRECOMMENDS_${PN}-crypt_append_class-target = " openssl ca-certificates"
312RRECOMMENDS_${PN}-crypt_append_class-nativesdk = " openssl ca-certificates"
313
314FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
315FILES_${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
316
317# provide python-pyvenv from python3-venv
318RPROVIDES_${PN}-venv += "python3-pyvenv"
319
320# package libpython3
321PACKAGES =+ "libpython3 libpython3-staticdev"
322FILES_libpython3 = "${libdir}/libpython*.so.*"
323FILES_libpython3-staticdev += "${prefix}/lib/python${PYTHON_MAJMIN}/config-${PYTHON_BINABI}-*/libpython${PYTHON_BINABI}.a"
324INSANE_SKIP_${PN}-dev += "dev-elf"
325
326# catch all the rest (unsorted)
327PACKAGES += "${PN}-misc"
328RDEPENDS_${PN}-misc += "python3-core python3-email python3-codecs python3-pydoc python3-pickle"
329RDEPENDS_${PN}-modules_append_class-target = " python3-misc"
330RDEPENDS_${PN}-modules_append_class-nativesdk = " python3-misc"
331FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
332
333# catch manpage
334PACKAGES += "${PN}-man"
335FILES_${PN}-man = "${datadir}/man"
336
337# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
338RDEPENDS_libpython3_append_libc-glibc = " libgcc"
339RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2 libgcc tzdata-europe coreutils sed"
340RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-tr-tr.iso-8859-9"
341RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk tk-lib', '', d)}"
342RDEPENDS_${PN}-dev = ""
343