summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.7.4.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-08-05 02:38:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-18 14:42:13 +0000
commit3370830012eee08b158d0fb8a00640d94c2eb210 (patch)
treedb4128feb1f01692a29534c8681e0d5c1ee472d6 /meta/recipes-devtools/python/python3_3.7.4.bb
parenta2d2dba0bde2c1119eabb28fda23bcc7ea746ede (diff)
downloadpoky-3370830012eee08b158d0fb8a00640d94c2eb210.tar.gz
python3: fix the test_locale output format
Before this patch: # python3 -m test -v test_locale [snip] test_getsetlocale_issue1813 (test.test_locale.TestMiscellaneous) ... testing with ('tr_TR', 'ISO8859-9') ok [snip] After this patch: # python3 -m test -v test_locale [snip] test_getsetlocale_issue1813 (test.test_locale.TestMiscellaneous) ... testing with ('tr_TR', 'ISO8859-9')... ok [snip] Make the test ended with "... ok" is common in python unittest world, we should make it keep consistent with other test cases in case it may be ignored to record in the report if we use the common filter "... ok". [YOCTO #13298] (From OE-Core rev: 5b8022db53d9ef50ea35b034a6e27477038a508b) Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.7.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.4.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.4.bb b/meta/recipes-devtools/python/python3_3.7.4.bb
index bd86d515d8..a3933b5ee9 100644
--- a/meta/recipes-devtools/python/python3_3.7.4.bb
+++ b/meta/recipes-devtools/python/python3_3.7.4.bb
@@ -27,6 +27,7 @@ SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
27 file://crosspythonpath.patch \ 27 file://crosspythonpath.patch \
28 file://reformat_sysconfig.py \ 28 file://reformat_sysconfig.py \
29 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \ 29 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
30 file://0001-test_locale.py-correct-the-test-output-format.patch \
30 " 31 "
31 32
32SRC_URI_append_class-native = " \ 33SRC_URI_append_class-native = " \