diff options
author | Changqing Li <changqing.li@windriver.com> | 2018-10-23 13:22:18 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-01-07 14:38:39 +0000 |
commit | 82315924b79b349b3798dd40786a19ee4f474cd4 (patch) | |
tree | beabc1c48b7226f1a727d2d8487a1e9e0c651cb4 /meta/recipes-devtools/python/python3_3.5.6.bb | |
parent | 6a080d90e5001bde30e8a1ade68a02bcd8a29df3 (diff) | |
download | poky-82315924b79b349b3798dd40786a19ee4f474cd4.tar.gz |
python/python3: use cc_basename to replace CC for checking compiler
When working path contains "clang"/"gcc"/"icc", it might be part of $CC
because of the "--sysroot" parameter. That could cause judgement error
about clang/gcc/icc compilers.
eg: if build under /yocto/builds/xicc/, bitbake python, $CC will contains
xicc, will make $CC match *icc, but actuall xicc just folder name.
When "*icc" is matched, below errors are reported when
compiling python/python3:
x86_64-wrs-linux-gcc: error: strict: No such file or directory
x86_64-wrs-linux-gcc: error: unrecognized command line option '-fp-model'
Here use cc_basename to replace CC for checking compiler to avoid such
kind of issue.
(From OE-Core rev: 96383efa2726ed1bf7893332d726112a8552fc24)
Signed-off-by: Li Zhou <li.zhou@windriver.com>
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.5.6.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3_3.5.6.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb index b4f6e55535..d64cb18c38 100644 --- a/meta/recipes-devtools/python/python3_3.5.6.bb +++ b/meta/recipes-devtools/python/python3_3.5.6.bb | |||
@@ -44,6 +44,7 @@ SRC_URI += "\ | |||
44 | file://0004-bpo-33570-TLS-1.3-ciphers-for-OpenSSL-1.1.1-GH-6976.patch \ | 44 | file://0004-bpo-33570-TLS-1.3-ciphers-for-OpenSSL-1.1.1-GH-6976.patch \ |
45 | file://0005-bpo-30714-ALPN-changes-for-OpenSSL-1.1.0f-2305.patch \ | 45 | file://0005-bpo-30714-ALPN-changes-for-OpenSSL-1.1.0f-2305.patch \ |
46 | file://run-ptest \ | 46 | file://run-ptest \ |
47 | file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \ | ||
47 | " | 48 | " |
48 | 49 | ||
49 | inherit multilib_header python3native update-alternatives qemu ptest | 50 | inherit multilib_header python3native update-alternatives qemu ptest |