diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2017-08-04 04:18:45 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-08-13 09:27:37 +0100 |
commit | 365b18dbef1e28db4688129cc3ad3db111b03285 (patch) | |
tree | 7596bb1b4621ed55ef69c8c49b49aebbecae9002 /meta/recipes-devtools/python/python3_3.5.3.bb | |
parent | 03eb3b4670f5c99e5039ff2ae7e681cdea9b6d44 (diff) | |
download | poky-365b18dbef1e28db4688129cc3ad3db111b03285.tar.gz |
python2/python3: fix multiprocessing.BoundedSemaphore not work on qemux86/qemuarm
In upstream, the following commit:
https://github.com/python/cpython/commit/e711cafab13efc9c1fe6c5cd75826401445eb585
...
commit e711cafab13efc9c1fe6c5cd75826401445eb585
Author: Benjamin Peterson <benjamin@python.org>
Date: Wed Jun 11 16:44:04 2008 +0000
Merged revisions 64104,64117 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
...
(see diff in setup.py)
It assigned libraries for multiprocessing module according
the host_platform, but not pass it to Extension.
In glibc, the following commit caused two definition of
sem_getvalue are different.
https://sourceware.org/git/?p=glibc.git;a=commit;h=042e1521c794a945edc43b5bfa7e69ad70420524
(see diff in nptl/sem_getvalue.c for detail)
`__new_sem_getvalue' is the latest sem_getvalue@@GLIBC_2.1
and `__old_sem_getvalue' is to compat the old version
sem_getvalue@GLIBC_2.0.
If not explicitly link to library pthread (-lpthread), it will
load glibc's sem_getvalue randomly at runtime.
Such as build python on linux x86_64 host and run the python
on linux x86_32 target. If not link library pthread, it caused
multiprocessing bounded semaphore could not work correctly.
...
>>> import multiprocessing
>>> pool_sema = multiprocessing.BoundedSemaphore(value=1)
>>> pool_sema.acquire()
True
>>> pool_sema.release()
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ValueError: semaphore or lock released too many times
...
And the semaphore issue also caused multiprocessing.Queue().put() hung.
(From OE-Core rev: ca1542cdf6b6437a2f3dcdb33ac5216bf841c04a)
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.5.3.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3_3.5.3.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.3.bb b/meta/recipes-devtools/python/python3_3.5.3.bb index 7419c71515..b67aec9fc0 100644 --- a/meta/recipes-devtools/python/python3_3.5.3.bb +++ b/meta/recipes-devtools/python/python3_3.5.3.bb | |||
@@ -38,6 +38,7 @@ SRC_URI += "\ | |||
38 | file://upstream-random-fixes.patch \ | 38 | file://upstream-random-fixes.patch \ |
39 | file://0001-Issue-21272-Use-_sysconfigdata.py-to-initialize-dist.patch \ | 39 | file://0001-Issue-21272-Use-_sysconfigdata.py-to-initialize-dist.patch \ |
40 | file://Fix-29519-weakref-spewing-exceptions-during-interp-f.patch \ | 40 | file://Fix-29519-weakref-spewing-exceptions-during-interp-f.patch \ |
41 | file://pass-missing-libraries-to-Extension-for-mul.patch \ | ||
41 | " | 42 | " |
42 | SRC_URI[md5sum] = "57d1f8bfbabf4f2500273fb0706e6f21" | 43 | SRC_URI[md5sum] = "57d1f8bfbabf4f2500273fb0706e6f21" |
43 | SRC_URI[sha256sum] = "eefe2ad6575855423ab630f5b51a8ef6e5556f774584c06beab4926f930ddbb0" | 44 | SRC_URI[sha256sum] = "eefe2ad6575855423ab630f5b51a8ef6e5556f774584c06beab4926f930ddbb0" |