diff options
author | Dominic Sacré <dominic.sacre@gmx.de> | 2015-07-28 16:58:35 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-08-01 22:24:17 +0100 |
commit | 3c53a2bbd7f34ab729a3b1172a8f61d0b9f9857c (patch) | |
tree | 53d53578e40244a509a8e544ddc24530ad443566 /meta/recipes-devtools/python/python3_3.4.3.bb | |
parent | 016f5aed006cf74e44235a2039fc58f79566de08 (diff) | |
download | poky-3c53a2bbd7f34ab729a3b1172a8f61d0b9f9857c.tar.gz |
python3: detect libraries in STAGING_LIBDIR
Patch setup.py so that the detect_modules() function looks for required
libraries and headers in STAGING_LIBDIR / STAGING_INCDIR.
Without this patch, several extension modules are not built, even though
their dependencies are present in the compiler's search paths.
The result is the following warning, and ultimately incomplete packages:
| The necessary bits to build these optional modules were not found:
| _bz2 _curses_panel _dbm
| _gdbm _lzma _sqlite3
| nis readline zlib
| To find the necessary bits, look in setup.py in detect_modules() for the module's name.
With the Python 3.3 version of the recipe, at least some of these modules
were built, because STAGING_LIBDIR happened to be in the search path
by coincidence. Due to changes to distutils in Python 3.4, this is no
longer the case.
A previous patch that only affects the search paths for SSL is dropped, as
this one is a more complete fix for [YOCTO #7768].
Part of the fix for [YOCTO #8048].
(From OE-Core rev: 540a223fc0fb6b07dab3316de6236924bd97613c)
Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.4.3.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3_3.4.3.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.4.3.bb b/meta/recipes-devtools/python/python3_3.4.3.bb index dce778a593..e2d9f796f1 100644 --- a/meta/recipes-devtools/python/python3_3.4.3.bb +++ b/meta/recipes-devtools/python/python3_3.4.3.bb | |||
@@ -36,7 +36,7 @@ SRC_URI += "\ | |||
36 | file://python3-setup.py-no-host-headers-libs.patch \ | 36 | file://python3-setup.py-no-host-headers-libs.patch \ |
37 | file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \ | 37 | file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \ |
38 | file://setup.py-check-cross_compiling-when-get-FLAGS.patch \ | 38 | file://setup.py-check-cross_compiling-when-get-FLAGS.patch \ |
39 | file://fix_ssl_include_dir.patch \ | 39 | file://setup.py-find-libraries-in-staging-dirs.patch \ |
40 | " | 40 | " |
41 | SRC_URI[md5sum] = "7d092d1bba6e17f0d9bd21b49e441dd5" | 41 | SRC_URI[md5sum] = "7d092d1bba6e17f0d9bd21b49e441dd5" |
42 | SRC_URI[sha256sum] = "b5b3963533768d5fc325a4d7a6bd6f666726002d696f1d399ec06b043ea996b8" | 42 | SRC_URI[sha256sum] = "b5b3963533768d5fc325a4d7a6bd6f666726002d696f1d399ec06b043ea996b8" |