summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.4.3.bb
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2016-04-11 00:29:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-11 22:02:04 +0100
commitbdd03ee4324122fb0ff50426447de9dbb451381e (patch)
treec46721bc6b9577e43239ad91298300ba9c5f8aa2 /meta/recipes-devtools/python/python3_3.4.3.bb
parent87f7f062dfcd5c05b6bea3cfe7b8d3dd7e375ce4 (diff)
downloadpoky-bdd03ee4324122fb0ff50426447de9dbb451381e.tar.gz
python3: fix building nativesdk-python3
When the class nativesdk.bbclass is inherited, it redefines TARGET_CC_ARCH, in the case of python3, this enables debug, causing an error while linking. Since we don't enable debug during configure some functions are not declared. This patch makes sure we keep debug disabled, fixing the linking errors. [YOCTO #9357] (From OE-Core rev: 2dd22dff121b3effe40abe4370de89231785a823) Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.4.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.4.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.4.3.bb b/meta/recipes-devtools/python/python3_3.4.3.bb
index f61d278d79..4f4e79cfd7 100644
--- a/meta/recipes-devtools/python/python3_3.4.3.bb
+++ b/meta/recipes-devtools/python/python3_3.4.3.bb
@@ -61,6 +61,7 @@ CACHED_CONFIGUREVARS = "ac_cv_have_chflags=no \
61TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__" 61TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
62TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__" 62TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
63TARGET_CC_ARCH += "-DNDEBUG -fno-inline" 63TARGET_CC_ARCH += "-DNDEBUG -fno-inline"
64SDK_CC_ARCH += "-DNDEBUG -fno-inline"
64EXTRA_OEMAKE += "CROSS_COMPILE=yes" 65EXTRA_OEMAKE += "CROSS_COMPILE=yes"
65EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ --without-ensurepip" 66EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ --without-ensurepip"
66 67