diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2015-01-12 18:55:19 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-01-16 23:08:27 +0000 |
commit | 55a45864ead1a47b144b3c4583e82c086700d16f (patch) | |
tree | b8991a36e4e4b5267c38b0fb0d40b9ae9b2d31cf /meta/recipes-devtools/python/python3_3.3.3.bb | |
parent | 84a76b28eafe6cbca79beea60909f10008db47fc (diff) | |
download | poky-55a45864ead1a47b144b3c4583e82c086700d16f.tar.gz |
python: fix B != S
And bump PR to avoid:
gcc: error: Parser/tokenizer_pgen.o: No such file or directory
gcc: error: Parser/printgrammar.o: No such file or directory
gcc: error: Parser/pgenmain.o: No such file or directory
(From OE-Core rev: aea42f59c8331c4d5944f698453bfd663aa0c59d)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.3.3.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3_3.3.3.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3_3.3.3.bb b/meta/recipes-devtools/python/python3_3.3.3.bb index 2c1f63f5b8..efa98c09fa 100644 --- a/meta/recipes-devtools/python/python3_3.3.3.bb +++ b/meta/recipes-devtools/python/python3_3.3.3.bb | |||
@@ -76,7 +76,7 @@ do_configure_prepend() { | |||
76 | 76 | ||
77 | do_compile() { | 77 | do_compile() { |
78 | # regenerate platform specific files, because they depend on system headers | 78 | # regenerate platform specific files, because they depend on system headers |
79 | cd Lib/plat-linux* | 79 | cd ${S}/Lib/plat-linux* |
80 | include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ | 80 | include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ |
81 | ${S}/Tools/scripts/h2py.py -i '(u_long)' \ | 81 | ${S}/Tools/scripts/h2py.py -i '(u_long)' \ |
82 | ${STAGING_INCDIR}/dlfcn.h \ | 82 | ${STAGING_INCDIR}/dlfcn.h \ |
@@ -108,7 +108,7 @@ do_compile() { | |||
108 | install -m 0644 Makefile Makefile.sysroot | 108 | install -m 0644 Makefile Makefile.sysroot |
109 | 109 | ||
110 | export CROSS_COMPILE="${TARGET_PREFIX}" | 110 | export CROSS_COMPILE="${TARGET_PREFIX}" |
111 | export PYTHONBUILDDIR="${S}" | 111 | export PYTHONBUILDDIR="${B}" |
112 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python3-native/pgen \ | 112 | oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python3-native/pgen \ |
113 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python3-native/python3 \ | 113 | HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python3-native/python3 \ |
114 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | 114 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
@@ -136,7 +136,7 @@ do_install() { | |||
136 | install -m 0644 Makefile.orig Makefile | 136 | install -m 0644 Makefile.orig Makefile |
137 | 137 | ||
138 | export CROSS_COMPILE="${TARGET_PREFIX}" | 138 | export CROSS_COMPILE="${TARGET_PREFIX}" |
139 | export PYTHONBUILDDIR="${S}" | 139 | export PYTHONBUILDDIR="${B}" |
140 | install -d ${D}${libdir}/pkgconfig | 140 | install -d ${D}${libdir}/pkgconfig |
141 | install -d ${D}${libdir}/python${PYTHON_MAJMIN}/config | 141 | install -d ${D}${libdir}/python${PYTHON_MAJMIN}/config |
142 | 142 | ||