summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wheel_0.38.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-11-13 11:08:10 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-14 16:19:43 +0000
commit312975e571eef3de318203a4c5f983197bd50f23 (patch)
tree599354e8866e6eefb7b471ed4ab13151c1796283 /meta/recipes-devtools/python/python3-wheel_0.38.4.bb
parentca040077063aee177bae96968f8e3e7e59c286ca (diff)
downloadpoky-312975e571eef3de318203a4c5f983197bd50f23.tar.gz
python3-wheel: upgrade 0.38.0 -> 0.38.4
Changelog: =========== -Fixed PKG-INFO conversion in bdist_wheel mangling UTF-8 header values in METADATA -Fixed install failure when used with --no-binary, reported on Ubuntu 20.04, by removing setup_requires from setup.cfg -Fixed regression introduced in v0.38.1 which broke parsing of wheel file names with multiple platform tags -Removed install dependency on setuptools -The future-proof fix in 0.36.0 for converting PyPy's SOABI into a abi tag was faulty. Fixed so that future changes in the SOABI will not change the tag. (From OE-Core rev: 85479f94c85d6928d6fd893bb28b86b2e769a07c) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-wheel_0.38.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wheel_0.38.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-wheel_0.38.4.bb b/meta/recipes-devtools/python/python3-wheel_0.38.4.bb
new file mode 100644
index 0000000000..6263cbc45c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-wheel_0.38.4.bb
@@ -0,0 +1,17 @@
1SUMMARY = "The official binary distribution format for Python "
2HOMEPAGE = "https://github.com/pypa/wheel"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a0148f94f483f3e1489"
6
7SRC_URI[sha256sum] = "965f5259b566725405b05e7cf774052044b1ed30119b5d586b2703aafe8719ac"
8
9inherit python_flit_core pypi
10
11SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
12
13BBCLASSEXTEND = "native nativesdk"
14
15# This used to use the bootstrap install which didn't compile. Until we bump the
16# tmpdir version we can't compile the native otherwise the sysroot unpack fails
17INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"