summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wcwidth_0.2.6.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-02-03 09:50:33 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-04 17:02:10 +0000
commit5cba8c7e742adac2ace9522460392d4a1ad49073 (patch)
tree022822af9c6aa17cd4d3da22186a3a32d43bdd8d /meta/recipes-devtools/python/python3-wcwidth_0.2.6.bb
parent2df069c72526e1ab3f606f07985a012c8d4387a7 (diff)
downloadpoky-5cba8c7e742adac2ace9522460392d4a1ad49073.tar.gz
python3-wcwidth: upgrade 0.2.5 -> 0.2.6
https://github.com/jquast/wcwidth#history 0.2.6 2023-01-14 * Updated tables to include Unicode Specification 14.0.0 and 15.0.0. * Changed developer tools to use pip-compile, and to use jinja2 templates for code generation in bin/update-tables.py to prepare for possible compiler optimization release. (From OE-Core rev: 0c09ede1fad284b8efd3b6ff3102d8dbb7efb5f4) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-wcwidth_0.2.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wcwidth_0.2.6.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-wcwidth_0.2.6.bb b/meta/recipes-devtools/python/python3-wcwidth_0.2.6.bb
new file mode 100644
index 0000000000..368146dba4
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-wcwidth_0.2.6.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Library for building powerful interactive command lines in Python"
2DESCRIPTION = "Measures the displayed width of unicode strings in a terminal"
3HOMEPAGE = "https://github.com/jquast/wcwidth"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb"
6
7SRC_URI[sha256sum] = "a5220780a404dbe3353789870978e472cfe477761f06ee55077256e509b156d0"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24BBCLASSEXTEND = "native nativesdk"