summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wcwidth_0.2.13.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-03-06 07:42:23 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-07 17:25:03 +0000
commit8479b1d2f9c69e663b84c6ec93e962cae5fc350c (patch)
treef82bd3ed386fd884bcbcf3edafca8c60d7a90f47 /meta/recipes-devtools/python/python3-wcwidth_0.2.13.bb
parent51460be41f5c9a047a6da3ebf1dcaa7d331352fe (diff)
downloadpoky-8479b1d2f9c69e663b84c6ec93e962cae5fc350c.tar.gz
python3-wcwidth: upgrade 0.2.12 -> 0.2.13
(From OE-Core rev: 800f18b387463a96f3e0642a06f7c4ff5fe85da9) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-wcwidth_0.2.13.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wcwidth_0.2.13.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-wcwidth_0.2.13.bb b/meta/recipes-devtools/python/python3-wcwidth_0.2.13.bb
new file mode 100644
index 0000000000..4a9bf75323
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-wcwidth_0.2.13.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Library for building powerful interactive command lines in Python"
2DESCRIPTION = "Measures the displayed width of unicode strings in a terminal"
3HOMEPAGE = "https://github.com/jquast/wcwidth"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb"
6
7SRC_URI[sha256sum] = "72ea0c06399eb286d978fdedb6923a9eb47e1c486ce63e9b4e64fc18303972b5"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 python3-pytest \
17 python3-unittest-automake-output \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23 install -d ${D}${PTEST_PATH}/bin
24 cp -rf ${S}/bin/* ${D}${PTEST_PATH}/bin/
25}
26
27BBCLASSEXTEND = "native nativesdk"