summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-spdx-tools_0.8.2.bb
diff options
context:
space:
mode:
authorMarta Rybczynska <rybczynska@gmail.com>2023-11-02 13:45:44 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-05 11:28:32 +0000
commitefe9ae014989d08d58bfbe99411b8b9cd05abdb6 (patch)
tree8c0e2bdf2035df61300b906ca2f16e4df6319d3d /meta/recipes-devtools/python/python3-spdx-tools_0.8.2.bb
parent9d2c9394eb1a686d49fe1df1704e805b0c6146aa (diff)
downloadpoky-efe9ae014989d08d58bfbe99411b8b9cd05abdb6.tar.gz
python3-spdx-tools: upgrade 0.8.1 -> 0.8.2
Changelog: added optional encoding parameter for parsing files fixed handling of the FilesAnalyzed field in Tag-Value format fixed the validation of the DownloadLocation field fixed the error handling while parsing license expressions fixed output of timezone-sensitive datetimes added code architecture documentation (From OE-Core rev: 70cfcb9ffadf463c3f96b97925db958e8c65af9d) Signed-off-by: Marta Rybczynska <marta.rybczynska@syslinbit.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-spdx-tools_0.8.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-spdx-tools_0.8.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-spdx-tools_0.8.2.bb b/meta/recipes-devtools/python/python3-spdx-tools_0.8.2.bb
new file mode 100644
index 0000000000..53263ca032
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-spdx-tools_0.8.2.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Python tool to parse, validate and convert spdx files"
2HOMEPAGE = "https://github.com/spdx/tools-python"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dc7f21ccff0f672f2a7cd6f412ae627d"
6
7SRC_URI[sha256sum] = "aea4ac9c2c375e7f439b1cef5ff32ef34914c083de0f61e08ed67cd3d9deb2a9"
8
9BBCLASSEXTEND = "native nativesdk"
10
11inherit setuptools3 pypi
12
13# Dependency required for pyspdxtools : python3-click
14# Dependencies required for conversion to spdx3 : python3-semantic-version, python3-ply
15RDEPENDS:${PN} += "\
16 python3-core \
17 python3-beartype \
18 python3-click \
19 python3-datetime \
20 python3-json \
21 python3-license-expression \
22 python3-ply \
23 python3-pyyaml \
24 python3-rdflib \
25 python3-semantic-version \
26 python3-uritools \
27 python3-xmltodict \
28 "