summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 15:57:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-13 14:00:52 +0000
commit36086ded7e72e3c249f3e221acbe7c0c3d3543d9 (patch)
treeae50c1a3921ad0a7bbc9fa6c60262d64a40624dd /meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
parent8aa71adf4932b4a7e62c1d66c3de25faa3db23c2 (diff)
downloadpoky-36086ded7e72e3c249f3e221acbe7c0c3d3543d9.tar.gz
python-setuptools: upgrade to 38.2.4; use pypi.bbclass; improvements
* Simplify python- and python3-setuptools with pypi.bbclass * inherit setuptools rather than distutils * Consolidate common settings in python-setuptools.inc - use PYTHON_PN variable to eliminate duplication - python3-setuptools had missing RDEPENDS (e.g., plistlib) - installer no longer creates setuptools.pth, drop fixes (From OE-Core rev: 624a6f209248a0c8e0759d43f246c903a8db6a71) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_36.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_36.5.0.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
deleted file mode 100644
index 63f241809e..0000000000
--- a/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1require python-setuptools.inc
2
3DEPENDS += "python3"
4DEPENDS_class-native += "python3-native"
5DEPENDS_class-nativesdk += "nativesdk-python3"
6
7inherit distutils3
8
9DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
10
11# The installer puts the wrong path in the setuptools.pth file. Correct it.
12do_install_append() {
13 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
14 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
15 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
16}
17
18RDEPENDS_${PN}_class-native = "\
19 python3-distutils \
20 python3-compression \
21"
22RDEPENDS_${PN} = "\
23 python3-ctypes \
24 python3-distutils \
25 python3-email \
26 python3-importlib \
27 python3-numbers \
28 python3-compression \
29 python3-shell \
30 python3-subprocess \
31 python3-textutils \
32 python3-pkgutil \
33 python3-threading \
34 python3-misc \
35 python3-unittest \
36 python3-xml \
37"
38BBCLASSEXTEND = "native nativesdk"